Bug 843079 - Application status set to "Some instances are not running" even when the instance are stopped
Application status set to "Some instances are not running" even when the inst...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jan Provaznik
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 10:12 EDT by Rehana
Modified: 2012-12-04 10:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when stopping all instances in an application resulted in an application status of: "Some instances are not running". This fix checks the state of all instances in an application and sets the application status to "stopped" if all its instances have stopped.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:15:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Instance state not reported correctly by conductor. (7.56 KB, image/png)
2012-08-09 06:44 EDT, Milan Falešník
no flags Details

  None (edit)
Description Rehana 2012-07-25 10:12:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to conductor
2.launch instance 
3.stop instance from the instane page
4. Observe the applicatio status 
  
Actual results:
Observed that the application status was set to "Some instances are not running"

Expected results:
Should be changed to stop, when all the instances are stopped


Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-cli-0.6.0-0.20120723230034git2a28761.fc16.noarch
aeolus-conductor-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120723230037git05a815a.fc16.noarch
aeolus-conductor-doc-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
aeolus-all-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
aeolus-configure-2.7.0-0.20120723230032gitcc8302d.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120725030008gitcdc50c9.fc16.noarch
Comment 1 Dave Johnson 2012-07-26 09:51:17 EDT
related to bug 816194
Comment 3 Milan Falešník 2012-08-09 06:44:05 EDT
Created attachment 603232 [details]
Instance state not reported correctly by conductor.

This bug is still present in aeolus-conductor-0.13.1-1.el6cf.noarch. I tested that with internal RHEV-M. Screenshot follows.
Comment 4 Jan Provaznik 2012-08-09 07:15:53 EDT
This patch is not pushed yet (thus the 'assigned' state) so it's not included in any packages yet.
Comment 5 Steve Linabery 2012-08-17 16:03:02 EDT
0df538b on 1.1 branch
Comment 7 Aziza Karol 2012-09-20 08:28:22 EDT
Application state is set to "All Instances are stopped" when all instances are stopped.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
Comment 9 errata-xmlrpc 2012-12-04 10:15:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.