Bug 843088 - -devel subpackage should use numpy/ namespace
-devel subpackage should use numpy/ namespace
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: python26-numpy (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Traylen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 10:45 EDT by Gianluca Sforna
Modified: 2017-03-24 04:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-24 04:55:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Sforna 2012-07-25 10:45:43 EDT
I'm trying to build an rpm against python26-numpy-devel package but failing because the project includes numpy headers like this:

#include <numpy/arrayobject.h>

while the -devel subpackage installs them directly in

/usr/include/python26-numpy

So I think headers should be moved in a numpy/ subdirectory
Comment 1 Steve Traylen 2015-11-03 05:09:15 EST
I am never going to fix this. .el5 simply to old to contemplate.
Comment 2 Gianluca Sforna 2015-11-03 13:41:31 EST
Right now, I don't even remember what I needed this for :)

However, I guess the same applies to newer EL releases, so you may still want to have a look at changing the installation directory for the devel files.
Comment 3 Steve Traylen 2017-03-24 04:55:33 EDT
Never going to fix this and python25 is .el5 only package.

Note You need to log in before you can comment on or make changes to this bug.