Bug 843105 - When mounting with live_ram, the CD is ejected and in some case we would like to be able to keep it inside the reader
Summary: When mounting with live_ram, the CD is ejected and in some case we would like...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-25 15:31 UTC by David Hill
Modified: 2013-02-21 10:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: When using the "live_ram" parameter for booting from live media, the dracut generated initramfs ejects the medium. Consequence: After ejecting the medium a reboot causes the machine to not boot from the medium again, even if this was desired. Fix: dracut now honors the "no_eject" kernel command line parameter. Result: If "no_eject" is given on the kernel command line, the dracut generated initramfs does not eject the live medium anymore after copying it to RAM.
Clone Of:
Environment:
Last Closed: 2013-02-21 10:29:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
No eject patch to dmsquash-live-root (790 bytes, text/plain)
2012-07-25 15:31 UTC, David Hill
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0436 normal SHIPPED_LIVE dracut bug fix and enhancement update 2013-02-20 20:48:34 UTC

Description David Hill 2012-07-25 15:31:42 UTC
Created attachment 600332 [details]
No eject patch to dmsquash-live-root

Description of problem:
If the CD is ejected and the server reboots, it won't boot again.

Version-Release number of selected component (if applicable):
Since dracut I guess

How reproducible:
Always.


Steps to Reproduce:
1. Create an image with livecd-creator with live_ram kernel parameter
2. Burn
3. Boot
4. CD will eject
  
Actual results:
CD ejects


Expected results:
Keep CD if needed


Additional info:
I created a patch but I don't know if it works.

Comment 2 Harald Hoyer 2012-07-26 07:07:11 UTC
agreed

Comment 4 Jan Stodola 2013-01-10 10:00:14 UTC
Reproduced with RHEL-6.3 (dracut-004-283.el6), retested with dracut-004-303.el6.
CD is not ejected with "live_ram" and "no_eject" boot options.

Moving to VERIFIED.

Comment 5 errata-xmlrpc 2013-02-21 10:29:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0436.html


Note You need to log in before you can comment on or make changes to this bug.