Bug 843133 - Simple D program cannot link in Rawhide: "undefined reference to `curl_easy_setopt'"
Simple D program cannot link in Rawhide: "undefined reference to `curl_easy_s...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ldc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: MERCIER Jonathan
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 842778
  Show dependency treegraph
 
Reported: 2012-07-25 12:29 EDT by Richard W.M. Jones
Modified: 2012-07-26 13:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 13:15:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-25 12:29:54 EDT
Description of problem:

'avgtime' from https://github.com/jmcabo/avgtime

ldc2 avgtime.d
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_setopt'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_global_cleanup'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_init'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_slist_append'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_pause'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_slist_free_all'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_duphandle'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_perform'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_cleanup'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_global_init'
/usr/lib/gcc/x86_64-redhat-linux/4.7.1/../../../../lib64/libphobos-ldc.so: undefined reference to `curl_easy_strerror'
Error: linking failed:
status: 1
collect2: error: ld returned 1 exit status

Version-Release number of selected component (if applicable):

ldc-2-26.20120720git5f15b30.fc18.x86_64
ldc-druntime-2-26.20120720git5f15b30.fc18.x86_64
ldc-phobos-devel-2-26.20120720git5f15b30.fc18.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Compile avgtime.d program above.
Comment 1 Richard W.M. Jones 2012-07-25 12:30:32 EDT
Failed build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4328940
Comment 2 MERCIER Jonathan 2012-07-26 03:10:00 EDT
i will take a look thanks
Comment 3 MERCIER Jonathan 2012-07-26 10:12:26 EDT
should be fixed now with the newest release
Comment 4 Richard W.M. Jones 2012-07-26 13:15:32 EDT
This seems to be fixed now, thanks.

Note You need to log in before you can comment on or make changes to this bug.