Bug 843134 - After connection to agent-less guest with 16b colour depth, initial screen is black and gets drawn on change only
After connection to agent-less guest with 16b colour depth, initial screen is...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: beta
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 12:30 EDT by David Jaša
Modified: 2013-02-21 03:48 EST (History)
6 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:48:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-07-25 12:30:27 EDT
Description of problem:
After connection to agent-less guest with 16b colour depth, initial screen is black and gets drawn on change only

Version-Release number of selected component (if applicable):
spice-gtk-0.11-11.el6.x86_64
spice-server-0.10.1-10.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
windows xp guest
qxl 5.1.0.10012 (2011/10/05)

How reproducible:
always

Steps to Reproduce:
1. have and winxp guest, stop the vdagent if running
2. in display properties, switch the colour depth to 16
3. connect to the guest with spice-gtk-based client
  
Actual results:
guest screen is black till first change (redraw) such as clock change, monitor bar movement, drag area chooser movement, window movement or any other window part redraw

Expected results:
guest screen is rendered fully upon connection

Additional info:
filed against spice-gtk because this doesn't occur with spicec
Comment 1 David Blechter 2012-07-27 09:36:48 EDT
vdagent less use case has low priority
Comment 3 Christophe Fergeau 2012-09-18 10:07:41 EDT
I cannot reproduce this in f17 (spice-gtk-0.12-4.fc17/virt-viewer-0.5.3-1.fc17) nor with git master.
Comment 4 Marian Krcmarik 2012-10-11 08:54:02 EDT
(In reply to comment #3)
> I cannot reproduce this in f17
> (spice-gtk-0.12-4.fc17/virt-viewer-0.5.3-1.fc17) nor with git master.

Reproduced easily according to instructions. Just did exactly what it says:

1. have and winxp guest, stop the vdagent if running
2. in display properties, switch the colour depth to 16
3. connect to the guest with spice-gtk-based client

With RHEL client:
$ rpm -qa | egrep "spice-gtk|virt-viewer"
spice-gtk-python-0.14-2.el6.x86_64
spice-gtk-0.14-2.el6.x86_64
virt-viewer-0.5.2-11.el6.x86_64
spice-gtk-tools-0.14-2.el6.x86_64

and WINXP as guest (with latest unsigned qxl even)
Comment 5 Christophe Fergeau 2012-10-11 11:12:37 EDT
This bug only happens when the qxl driver is used, not when the cirrus driver is used, that's why I could not reproduce initially.
Comment 6 David Blechter 2012-10-15 14:02:28 EDT
Out of time for 6.4, not a blocker, moving to 6.5
Comment 7 Marc-Andre Lureau 2012-10-16 07:11:25 EDT
patch proposed on the mailing list
Comment 9 Marc-Andre Lureau 2012-12-10 08:08:58 EST
Fixed in spice-gtk-0.14-5.el6
Comment 13 errata-xmlrpc 2013-02-21 03:48:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html

Note You need to log in before you can comment on or make changes to this bug.