Bug 84317 - Keyboard typing call unwanted menu via remote X terminal
Keyboard typing call unwanted menu via remote X terminal
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-14 06:43 EST by poueck
Modified: 2015-01-07 19:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-03 13:33:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description poueck 2003-02-14 06:43:13 EST
Description of problem:

From a remote X Terminal ( HP ENTRIA Enware v7.11 ), all gnome applications
reacting bad to keyboard input.
ie: in TextEdit for example: if you type 's', then it writes a 's' in the text,
bug if you type 'h' it directly open the Help menu, and it's not possible to
enter the 'h' letter in the text.

This problem occure in all gnome app ( gdm, gedit, gnome-terminal,...)

From X-Win32, this problem does not occur.

Under the same HP terminal, under KDE, all is working fine.

To discover this, firstly I was thinking that was a gdm bug, because, It was
impossible to log in with gdm. When I try to log in under the root user, when I
type the 'o' letter, it validates my entry and ask the password. I switch to kdm
to login the system

Of course, I try multiple keyboard on this terminal.

Version-Release number of selected component (if applicable):

Latest realease from RedHat 8.0 update

How reproducible: 


Steps to Reproduce:
1. Connecting from a HP Entria Terminal with XDCMP
2. On the login console, try to type 'root'
3. When you type the 'o' it acts like if you typed the enter key
Comment 1 Havoc Pennington 2003-02-14 12:14:50 EST
does it work if you open the gnome apps while in kde?

can you paste the KeyPress events from "xev" caused by typing the 
letters that don't work? also the output of "xmodmap -pm"?

thanks
Comment 2 poueck 2003-02-17 03:54:54 EST
Under kde and when running a gnome app, the same problem occurs.

Here is the result of "modmap -pm":

     xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):
     
     shift       Shift_L (0x1b),  Shift_R (0x62)
     lock        Caps_Lock (0x1d)
     control     Control_L (0x1a),  Control_R (0x61)
     mod1        Alt_L (0x22),  Alt_R (0x42),  Mode_switch (0x84)
     mod2      
     mod3      
     mod4      

mod5      

Here is the dump of xev on a gedit window when I type a 'h' in gedit

    VisibilityNotify event, serial 9, synthetic NO, window 0x4000002,
         state VisibilityPartiallyObscured

when I type a worked letter, nothing append in xev.

Without specifying a window id in xev, I see events when I type characters in 
xev own window
For exemple: the 'h' letter:

     KeyPress event, serial 19, synthetic NO, window 0x4000001,
         root 0x24, subw 0x4000002, time 858957305, (36,47), root:(48,107),
         state 0x0, keycode 42 (keysym 0x68, h), same_screen YES,
         XLookupString gives 1 characters:  "h"

     KeyRelease event, serial 21, synthetic NO, window 0x4000001,
         root 0x24, subw 0x4000002, time 858957375, (36,47), root:(48,107),
         state 0x0, keycode 42 (keysym 0x68, h), same_screen YES,
         XLookupString gives 1 characters:  "h"

But this event does not occur in a gnome application.
The report of xev under console or my HP X Terminal are the same.
Comment 3 Havoc Pennington 2003-02-17 11:14:29 EST
I think the problem is having Alt and Mode_switch on the same modifier bit.
You need to fix the X terminal not to do that, it doesn't make any sense.
Comment 4 Havoc Pennington 2003-02-18 14:48:28 EST
Can you try changing the keymap for your X terminal so that the xmodmap doesn't
have two functions on the same modifier bit, and let us know if that fixes it?

Note You need to log in before you can comment on or make changes to this bug.