Bug 84319 - Corrupt Windows98 partition prevents install or upgrade
Summary: Corrupt Windows98 partition prevents install or upgrade
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-14 12:46 UTC by Alan Horkan
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 16:47:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Horkan 2003-02-14 12:46:12 UTC
Description of problem:
Hardware:
Dell Dimension 4100 with a second 20GB IBM harddrive.   

I had a corrupt partition Windows98 Fat32X.  
This partition (before it became corrupted) had been mounted by my RedHat 7.2
installation.  
Anaconda would neither allow me to upgrade nor do a fresh install of RedHat 8.0
to my linux partitions because of this corrupt partition.  

[The first hardrive has Windows98 on it, the second harddrive had various
partitions Linux partitions on it with a large (~6GB or ~8GB, i forget) windows
partition at the end.  The windows partition on the second drive became
corrupted and i hope to at some point figure out what was wrong with it and
possibly recover the data.  Eventually i gave up and wiped the corrupt windows
partition.]

Comment 1 Jeremy Katz 2003-02-14 16:32:58 UTC
What sort of error did you get if you attempted to install or upgrade?

Comment 2 Alan Horkan 2003-02-14 16:40:39 UTC
It was a few weeks ago and it is difficult to remember.  

I think it was something relatively simple like
'unable to mount partition' and then start again, or words to that effect.  

Sorry i cannot be more specific.  

If perhaps there is a copy of the anaconda source in LXR or something i can
browse online i would be willing to look through and see if i can recognise the
error that occured.  

Thanks for your time, it is a pretty obscure problem I almost did not think it
was worth reporting.  



Comment 3 Jeremy Katz 2003-02-14 16:47:05 UTC
On an upgrade, if you have a filesystem listed in your fstab that can't be
mounted, then yes, you would get that error and it's not something that's really
fixable (how do you define a "necessary" partition, especially when people start
symlinking things when they run out of space).  I'd expect a fresh install where
you weren't trying to mount the partition to work, though.


Note You need to log in before you can comment on or make changes to this bug.