Bug 843194 - Support v7 call home to compare test plans using the certify command
Support v7 call home to compare test plans using the certify command
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.6.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On: 842409
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 17:04 EDT by Rob Landry
Modified: 2013-02-01 13:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: v7 should support call home to the catalog with a given cert ID to retrieve the list of open (non-confirmed) test classes that apply to the certification when using the certify command. The list of opens is compared to the possibles after the list of tests v7 already has passing results for is removed from the running plan. Reason: Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 13:20:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v7 certify patch to optionally check hw catalog for open tests (4.89 KB, patch)
2012-10-30 13:25 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Rob Landry 2012-07-25 17:04:02 EDT
Description of problem:

v7 should support call home to the catalog with a given cert ID to retrieve the list of open (non-confirmed) test classes that apply to the certification when using the certify command.  The list of opens is compared to the possibles after the list of tests v7 already has passing results for is removed from the running plan.

Version-Release number of selected component (if applicable):

1.6.4


Additional info:

As before the catalog will need to support this call.  On any errors v7 can  ignore this subtraction from the certify plan.  The the catalog also include the  "melted test plan" (or similar) error indicating that the testplan is not frozen which means no credit can be applied so it is not capable of responding with the remaining opens.
Comment 2 Greg Nichols 2012-10-30 13:25:34 EDT
Created attachment 635699 [details]
v7 certify patch to optionally check hw catalog for open tests
Comment 10 errata-xmlrpc 2013-02-01 13:20:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0222.html

Note You need to log in before you can comment on or make changes to this bug.