Bug 843199 - Ruby bindings segfault in event callbacks when the Ruby GC is invoked.
Ruby bindings segfault in event callbacks when the Ruby GC is invoked.
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On: 843188
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 17:35 EDT by Richard W.M. Jones
Modified: 2012-09-28 09:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 843188
Environment:
Last Closed: 2012-09-28 09:03:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker BGBUILD-371 Major Open segfault in boxgrinder-build 0.10.2 after update to ruby-libguestfs.i686 1:1.16.28-1.fc16 2015-09-10 04:23:27 EDT

  None (edit)
Description Richard W.M. Jones 2012-07-25 17:35:34 EDT
+++ This bug was initially created as a clone of Bug #843188 +++

Description of problem:

Initial report is here, with a partial stack trace:
https://issues.jboss.org/browse/BGBUILD-371

Version-Release number of selected component (if applicable):

libguestfs 1.16.28

How reproducible:

100%

Steps to Reproduce:
1. unknown at present

--- Additional comment from rjones@redhat.com on 2012-07-25 17:34:14 EDT ---

Created attachment 600404 [details]
bz843188.rb

This small script reproduces the bug.

Save it to a file, chmod +x the script and run it.  It will
cause a segfault.

If you comment out the line that calls g.set_event_callback
then it won't segfault, proving that the problem is with
events.
Comment 3 Richard W.M. Jones 2012-09-28 09:03:20 EDT
We got to the bottom of this bug (see:
https://bugzilla.redhat.com/show_bug.cgi?id=843188#c6)
and essentially the problem is that the Ruby 1.8 garbage
collector is broken by design.

This problem is unfixable, except by moving to Ruby 1.9
or not using Ruby.

Note You need to log in before you can comment on or make changes to this bug.