Bug 843238 - libharu package has not built for multiple Fedora releases
libharu package has not built for multiple Fedora releases
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libharu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alex Orlandi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2012-07-25 18:10 EDT by Bill Nottingham
Modified: 2014-03-16 23:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 16:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix direct accesses to libpng's private png_info struct (12.63 KB, patch)
2012-07-28 13:14 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2012-07-25 18:10:01 EDT
This package has not been built since Fedora 15, having failed multiple mass
rebuild cycles.

As part of the normal process for retiring packages that have not
successfully built, this package is scheduled to be removed from Fedora on
or around the Fedora 18 branch date (August 7th).

Please fix this as soon as possible.
Comment 1 Tom Lane 2012-07-28 13:13:22 EDT
The FTBFS problem is due to libpng no longer allowing direct access to struct png_info.  If there is any interest in reviving this package, I attach a patch to fix that.  I note though that the version we're packaging is obsolete upstream (cf bug #654755), and that the build is full of warnings like
warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O)
So it needs more attention than just applying this patch.
Comment 2 Tom Lane 2012-07-28 13:14:05 EDT
Created attachment 600935 [details]
fix direct accesses to libpng's private png_info struct
Comment 3 Tom "spot" Callaway 2012-07-31 16:40:57 EDT
I fixed this in basically the same way, except I conditionalized it so that the old code would be present and work for older libpngs.

Fixed in 2.2.1-1.fc18.
Comment 4 Tom Lane 2012-08-01 01:43:16 EDT
FWIW, I doubt that conditionalization is necessary --- we have not shipped libpng 1.0 in a very long time.  But anyway, thanks for fixing.
Comment 5 Tom "spot" Callaway 2012-08-01 09:41:40 EDT
It's clearly unnecessary for Fedora, but in several previous package fixes, the upstream wouldn't take the patch unless it was conditionalized.

Note You need to log in before you can comment on or make changes to this bug.