This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 843252 - Panini package has not built for multiple Fedora releases
Panini package has not built for multiple Fedora releases
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Panini (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2012-07-25 18:11 EDT by Bill Nottingham
Modified: 2014-03-16 23:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 22:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A VERY simple patch to fix building (1.39 KB, patch)
2012-07-25 19:08 EDT, Patrick Uiterwijk
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2012-07-25 18:11:37 EDT
This package has not been built since Fedora 15, having failed multiple mass
rebuild cycles.

As part of the normal process for retiring packages that have not
successfully built, this package is scheduled to be removed from Fedora on
or around the Fedora 18 branch date (August 7th).

Please fix this as soon as possible.
Comment 1 Patrick Uiterwijk 2012-07-25 19:08:46 EDT
Created attachment 600408 [details]
A VERY simple patch to fix building

This simple patch fixes building.
It makes the building import libGLU.

Proof of building in rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=4329916
Comment 2 Patrick Uiterwijk 2012-07-25 19:10:03 EDT
I hope someone can apply this patch.
Comment 3 Ankur Sinha (FranciscoD) 2012-07-25 19:29:41 EDT
(In reply to comment #2)
> I hope someone can apply this patch.

I'll look into this over the next few days. Thank you for the patch Patrick.

Ankur
Comment 4 Patrick Uiterwijk 2012-07-26 07:30:21 EDT
Apearantly the git patch has some problems (maybe because of all the control characters in panini-qmake-link-FTBFS-patch.
The real fix is just this single patch:

--- panini-qmake-link-FTBFS-patch	2012-07-26 13:28:39.228550708 +0200
+++ panini-qmake-link-FTBFS-patch	2012-07-26 13:28:50.554941255 +0200
@@ -9,7 +9,7 @@ diff -u ../Panini-0.71.103-src.orig/pani
  TARGET = Panini
  CONFIG += debug_and_release
  QT = gui core opengl
-+LIBS += -lz
++LIBS += -lz -lGLU
  
  # # Directories ##
  OBJECTS_DIR = build
Comment 5 Ankur Sinha (FranciscoD) 2012-07-27 22:00:43 EDT
Built for rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=344740

Building for F17/F16. Will push updates as soon as it's finished. 

Thank you for filing a bug report and providing the patch Patrick.

Ankur
Comment 6 Fedora Update System 2012-07-28 02:29:31 EDT
Panini-0.71.103-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/Panini-0.71.103-8.fc16
Comment 7 Fedora Update System 2012-07-28 02:29:41 EDT
Panini-0.71.103-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/Panini-0.71.103-8.fc17
Comment 8 Fedora Update System 2012-08-14 05:22:04 EDT
Panini-0.71.103-8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-08-21 05:48:35 EDT
Panini-0.71.103-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.