Bug 843270 - specto package has not built for multiple Fedora releases
specto package has not built for multiple Fedora releases
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: specto (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16FTBFS
  Show dependency treegraph
 
Reported: 2012-07-25 18:13 EDT by Bill Nottingham
Modified: 2014-03-16 23:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 11:04:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixes to the specto spec file (4.46 KB, patch)
2012-07-25 23:11 EDT, Theodore Lee
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2012-07-25 18:13:29 EDT
This package has not been built since Fedora 15, having failed multiple mass
rebuild cycles.

As part of the normal process for retiring packages that have not
successfully built, this package is scheduled to be removed from Fedora on
or around the Fedora 18 branch date (August 7th).

Please fix this as soon as possible.
Comment 1 Theodore Lee 2012-07-25 23:11:27 EDT
Created attachment 600424 [details]
Fixes to the specto spec file

I've been building my own Specto RPMs for personal use for a while now, and I'm fairly certain the build issue is a simple missing buildrequires for intltool. The attached patch shows the differences between the current specfile in git master and the one I use personally - diff picked up on quite a bit of the superfluous cleanup and whitespace tweaks I made, so apologies if it's a bit messy.

If it would help, I'd be happy to co-maintain specto.
Comment 2 Bill Nottingham 2012-07-26 14:20:29 EDT
Certainly, you can feel free to apply for comaintainership.
Comment 3 Theodore Lee 2012-07-26 20:10:20 EDT
I've requested commit rights in pkgdb.
Comment 4 Theodore Lee 2012-08-03 21:36:43 EDT
Could we perhaps get a provenpackager to add intltool to the build requirements and do a rebuild so this package doesn't end up blocked?
Comment 5 Bill Nottingham 2012-08-06 12:25:22 EDT
Done.
Comment 6 Mat Booth 2013-02-21 11:04:58 EST
This package appears to be building successfully these days, closing:

http://koji.fedoraproject.org/koji/packageinfo?packageID=3859

Note You need to log in before you can comment on or make changes to this bug.