Bug 843294 - Pixie FTBFS due to g++ getting stricter
Pixie FTBFS due to g++ getting stricter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Pixie (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 21:11 EDT by Tom Lane
Modified: 2013-07-02 23:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 14:06:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.55 KB, application/octet-stream)
2012-07-25 21:11 EDT, Tom Lane
no flags Details

  None (edit)
Description Tom Lane 2012-07-25 21:11:14 EDT
Created attachment 600421 [details]
proposed patch

Description of problem:
Pixie is failing to build because g++ will not (any longer?) implicitly cast a FILE* value to gzFile.  Which is a bit odd because gzFile is just a typedef for void *, but apparently it will no longer look through the typedef.  Anyway, the attached proposed patch gets it to build again.

Version-Release number of selected component (if applicable):
Pixie-2.2.6-8.fc18

How reproducible:
100%

Steps to Reproduce:
1.  Try to build in rawhide environment.
Comment 1 Gwyn Ciesla 2012-08-01 14:06:11 EDT
Committed and built in rawhide.

Note You need to log in before you can comment on or make changes to this bug.