Bug 843299 - poweroff, reboot missfunction
poweroff, reboot missfunction
Status: CLOSED DUPLICATE of bug 804088
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 21:27 EDT by M. A. MacLain
Modified: 2012-08-08 19:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 19:45:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M. A. MacLain 2012-07-25 21:27:36 EDT
Description of problem:

When "poweroff", "reboot" or "halt" is invoked from the /usr/bin/ directory, the comand is sent to "systemctl" via a link to "consolehelper".

When the command is invoked from the /usr/bin/ directory it is passed directly to "systemctl".

Thus I expected /usr/bin/poweroff to ask for authentication and /usr/sbin/poweroff execute immediatly.


Version-Release number of selected component (if applicable):

systemd-44-17.fc17.x86_64



How reproducible: All the time.


Steps to Reproduce:

Creat keyboard shortcuts as follows:

         Key      Command
         "Alt r"   /usr/bin/reboot 
         "Alt s"   /usr/sbin/poweroff

Test 1
1. Powered off and re-start box.
2. Log User.
3. Punch "Alt s".

Test 2
1. Powered off and re-start box.
2. Log User.
3. Punch "Alt r".

Actual results:
Test 1: Request for Administrator Authentication snipet displayed.
Test 2: An immediate reboot was executed.

Expected results:
Test 1: The system was expected to power off immediatly.
Test 2: The system was expected to request for Administrator Authentication

Additional info:
Comment 1 Kay Sievers 2012-08-08 19:45:00 EDT

*** This bug has been marked as a duplicate of bug 804088 ***

Note You need to log in before you can comment on or make changes to this bug.