Bug 843330 - libgdiplus FTBFS with current libpng
libgdiplus FTBFS with current libpng
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgdiplus (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 00:06 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 18:47:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (6.15 KB, patch)
2012-07-26 00:06 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 00:06:00 EDT
Created attachment 600433 [details]
proposed patch

Description of problem:
libgdiplus has failed to rebuild in the last two mass Fedora rebuilds.  The reason is that pngcodec.c expects it can access the contents of the PNG info struct, which is no longer made visible by libpng 1.5.

I attach a patch that I think fixes it.  It compiles anyway, which is a step forward, but I don't know anything about testing libgdiplus's PNG-reading functionality.

Version-Release number of selected component (if applicable):
libgdiplus-2.10-5.fc18

How reproducible:
100%

Steps to Reproduce:
1. Try to build in rawhide or F-17.
Comment 1 Christian Krause 2012-07-26 18:47:49 EDT
I have built libgdiplus in RAWHIDE using the following patch from gentoo:

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-dotnet/libgdiplus/files/libgdiplus-2.10.1-libpng15.patch?revision=1.1

To verify the PNG functionality I tried successfully:

- run the tests included in libgdiplus
- run some mono (winforms) applications which loads PNGs


RAWHIDE build:
https://koji.fedoraproject.org/koji/buildinfo?buildID=344329

Note You need to log in before you can comment on or make changes to this bug.