Bug 843397 - Allow manual invocation of Spice session (without browser plugin)
Allow manual invocation of Spice session (without browser plugin)
Status: CLOSED DUPLICATE of bug 843410
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Einav Cohen
yeylon@redhat.com
virt
: FutureFeature
Depends On:
Blocks: 843410
  Show dependency treegraph
 
Reported: 2012-07-26 04:45 EDT by Alon Bar-Lev
Modified: 2016-04-18 03:11 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 08:33:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Bar-Lev 2012-07-26 04:45:33 EDT
PROBLEM

1. oVirt does not support activating Spice session without plugin installed.

2. oVirt Supports Spice within specific browsers Internet Explorer and Firefox only.

3. If user does not has plugin or use unsupported browser, he cannot activate Spice session manually as he is able to in Vnc alternative.

4. Vnc does supports manual invocation.

MISSION

Align Spice to Vnc behavior for manual invocation.

SOLUTION

If plugin is not detected present a dialog with the following information:

1. Spice plugin was not detected, for best integration please _download_ and install.

2. Manual invocation is possible using the following information:

a. Host: <name/ip>
b. Port: <port>
c. Password: <ticket>
d. CA: Click _here_ to download CA certificate.

FUTURE DESIGN

Both Vnc and Spice activation can download MIME type configuration to automatically luanch Vnc/Spice client at client side without any plugin.
Comment 1 Marc-Andre Lureau 2012-08-02 07:51:49 EDT
On Linux, an application can register to handle a URI. There might be a similar approach possbile on Windows. Currently the spice:// URI can't contain the CA, but as long as it is the same accross various connections, the user can save it once and use it again. It would make sense to have CA store that is automatically looked up in Spice client.
Comment 2 Alon Bar-Lev 2012-08-02 08:10:49 EDT
(In reply to comment #1)
> On Linux, an application can register to handle a URI. There might be a
> similar approach possbile on Windows. Currently the spice:// URI can't
> contain the CA, but as long as it is the same accross various connections,
> the user can save it once and use it again. It would make sense to have CA
> store that is automatically looked up in Spice client.

Hi,

I thought about this alternative, however we probably want to pass more information during execution, such as device redirection.

Reuse of same URL will be likely impossible as the password is really a ticket which expires upon use or shortly after.

So I believe the MIME approach is the simplest and has the chance to the largest coverage (bug#843410).

Alon
Comment 3 Michal Skrivanek 2012-09-25 08:33:13 EDT
ok, so let's concentrate on 843410 which seems to provide the complete solution.

*** This bug has been marked as a duplicate of bug 843410 ***
Comment 4 Alon Bar-Lev 2012-09-25 08:59:55 EDT
(In reply to comment #3)
> ok, so let's concentrate on 843410 which seems to provide the complete
> solution.
> 
> *** This bug has been marked as a duplicate of bug 843410 ***

I think that we can provide this bug for 3.1, it is all a matter of ~1 hour work for creating proper dialog, while bug#843410 is for future.
Comment 8 Alon Bar-Lev 2012-10-17 16:06:16 EDT
Andrew,
As a quick remedy for people able to install the spice xpi plugin, I suggest to include this in 3.1.
It is trivial, but allow people to access the spice console using the spice client.
Primitive but working.
Alon.

Note You need to log in before you can comment on or make changes to this bug.