Bug 843408 - changes in statedump
changes in statedump
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 04:58 EDT by Raghavendra Bhat
Modified: 2013-07-24 13:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:11:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-07-26 04:58:32 EDT
Description of problem:

We need some indication about starting of the statedump and the end of the statedump in the statedump file. This is needed because, suppose the filesystem is handling lot of i/o, then if the statedump is taken it takes some time to write all the information to the statedump file. If Ending marker is not there, then one cannot identify when statedump is completely written. 

Apart from that one more change needed is appending timestamp to the statedump filename. As of now pid is appended to the statedump file. But if statedump is taken on the same process again, then the old statedump information is lost. Appending timestamp to the filename will help in retaining old files also.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2012-07-30 14:17:08 EDT
CHANGE: http://review.gluster.com/3738 (libglusterfs/statedump: add start and end markers in the statedump file) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.