Bug 843428 - webkitgtk3-1.9.5-1.fc18 is FTBFS on ARM
webkitgtk3-1.9.5-1.fc18 is FTBFS on ARM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: webkitgtk3 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-07-26 06:00 EDT by Peter Robinson
Modified: 2012-08-14 15:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: webkitgtk3-1.9.5-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 15:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-07-26 06:00:31 EDT
1.9.5 fails, 1.9.3 built fine. Can't test 1.9.4 as it was FTB on mainline too

koji task: http://arm.koji.fedoraproject.org/taskinfo?taskID=1001042

relevant failure:

./Source/JavaScriptCore/heap/Heap.h: At global scope:
./Source/JavaScriptCore/heap/Heap.h:237:9: error: 'JITStubRoutineSet' does not name a type
In file included from ./Source/WTF/wtf/text/WTFString.h:28:0,
                 from ./Source/WTF/wtf/DateMath.h:54,
                 from ./Source/JavaScriptCore/runtime/JSDateMath.h:46,
                 from ./Source/JavaScriptCore/runtime/DateInstanceCache.h:29,
                 from ./Source/JavaScriptCore/runtime/JSGlobalData.h:33,
                 from ./Source/JavaScriptCore/interpreter/CallFrame.h:27,
                 from ./Source/JavaScriptCore/runtime/ArgList.h:25,
                 from ./Source/JavaScriptCore/runtime/JSObject.h:26,
                 from ./Source/JavaScriptCore/runtime/InternalFunction.h:27,
                 from ./Source/JavaScriptCore/runtime/JSFunction.h:27,
                 from ./Source/JavaScriptCore/bytecode/CallLinkInfo.h:31,
                 from ./Source/JavaScriptCore/bytecode/CodeBlock.h:34,
                 from Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp:28:
./Source/WTF/wtf/text/ASCIIFastPath.h: In instantiation of 'bool WTF::charactersAreAllASCII(const CharacterType*, size_t) [with CharacterType = unsigned char; size_t = unsigned int]':
./Source/WTF/wtf/text/WTFString.h:524:69:   required from here
./Source/WTF/wtf/text/ASCIIFastPath.h:84:9: warning: cast from 'const unsigned char*' to 'const MachineWord* {aka const unsigned int*}' increases required alignment of target type [-Wcast-align]
./Source/WTF/wtf/text/ASCIIFastPath.h: In instantiation of 'bool WTF::charactersAreAllASCII(const CharacterType*, size_t) [with CharacterType = short unsigned int; size_t = unsigned int]':
./Source/WTF/wtf/text/WTFString.h:526:66:   required from here
./Source/WTF/wtf/text/ASCIIFastPath.h:84:9: warning: cast from 'const short unsigned int*' to 'const MachineWord* {aka const unsigned int*}' increases required alignment of target type [-Wcast-align]
make: *** [Source/JavaScriptCore/llint/Programs_LLIntOffsetsExtractor-LLIntOffsetsExtractor.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.pjrwOp (%build)
    Bad exit status from /var/tmp/rpm-tmp.pjrwOp (%build)
RPM build errors:
Comment 1 Brendan Conoboy 2012-08-04 02:09:41 EDT
FYI, this fails because the Heap code now requires JIT be enabled.  This is a change vs 1.9.3 where there was no such dependency in Heap.h/Heap.cpp.  I bet builds fail on PPC and s390 as well since JIT is hard coded off on them in the spec file.

For ARM it appears this was disabled for the following reason:

https://bugs.webkit.org/show_bug.cgi?id=85076

I'm doing a test build now with JIT re-enabled to see if it solves the build problem.  If it does we'll need to discern if the resulting package works or is the original problem reported to webkit.org still present?

If it is still present either the Heap code will need to have additional code added to support the non-JIT case, or the bug will need to be tracked down.
Comment 2 Simon Schampijer 2012-08-09 08:35:51 EDT
Brendan, did you try to make another build with the ARM JIT enabled if the issue had been fixed? I commented about this chicken/egg situation on https://bugs.webkit.org/show_bug.cgi?id=85076#c18
Comment 3 Brendan Conoboy 2012-08-09 11:05:36 EDT
Fails to build with JIT enabled for different reasons.
Comment 4 Daniel Drake 2012-08-09 12:24:29 EDT
This is fixed in http://trac.webkit.org/changeset/123107

Just doing a scratch build to make sure it works:
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1053533

If that succeeds, I'll push a new F18 package.
(the test build will take a few hours though)
Comment 5 Daniel Drake 2012-08-09 12:38:29 EDT
Test build failed due to other breakage. Will need to try again when source-highlight-3.1.6-3.fc18 has hit the ARM builders.
Comment 6 Daniel Drake 2012-08-13 14:50:44 EDT
Scratch build: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1063505
Comment 7 Daniel Drake 2012-08-13 22:08:28 EDT
Failed, also needs http://trac.webkit.org/changeset/124099 for new gcc/bison
New scratch build for testing: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1064493
Comment 8 Daniel Drake 2012-08-14 11:10:29 EDT
The scratch build succeeded, and I briefly tested it in sugar-browse. And looks like someone beat me to building it in real koji: http://koji.fedoraproject.org/koji/buildinfo?buildID=348075
Comment 9 Dan Horák 2012-08-14 11:18:45 EDT
(In reply to comment #8)
> The scratch build succeeded, and I briefly tested it in sugar-browse. And
> looks like someone beat me to building it in real koji:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=348075

yes, it was me as I didn't see you online on IRC, s390 also waits on new webkit :-)
Comment 10 Daniel Drake 2012-08-14 15:16:58 EDT
Thanks. The build has completed, so I'll close this bug.

Note You need to log in before you can comment on or make changes to this bug.