Bug 843429 - SD Card reader errors
SD Card reader errors
Status: CLOSED DUPLICATE of bug 871638
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 06:01 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 14:33:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-07-26 06:01:28 EDT
SD Card reader on a Thinkpad T520

lspci: 0d:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 05)
kernel: 3.4.4-4.fc16.x86_64 

Card is a Samsung 32GB MicroSD in an SD adapter. Tried with two different adapters - same result. Mounted the card via USB adapter, no problem.

Lots of errors like this: 

Jul 26 19:53:30 nitai kernel: [66948.748184] end_request: I/O error, dev mmcblk0, sector 439791
Jul 26 19:53:30 nitai kernel: [66948.748445] mmcblk0: error -84 sending status command, retrying
Jul 26 19:53:30 nitai kernel: [66948.748479] mmcblk0: error -84 sending status command, retrying
Jul 26 19:53:30 nitai kernel: [66948.748506] mmcblk0: error -84 transferring data, sector 439792, nr 2, cmd response 0x900, card status 0x0
Jul 26 19:53:30 nitai kernel: [66948.748508] end_request: I/O error, dev mmcblk0, sector 439792
Jul 26 19:53:30 nitai kernel: [66948.748771] mmcblk0: error -84 sending status command, retrying
Jul 26 19:53:30 nitai kernel: [66948.748797] mmcblk0: error -84 transferring data, sector 439793, nr 1, cmd response 0x900, card status 0x0
Jul 26 19:53:30 nitai kernel: [66948.748802] end_request: I/O error, dev mmcblk0, sector 439793
Jul 26 19:53:36 nitai kernel: [66954.495338] mmcblk0: error -110 transferring data, sector 4321650, nr 8, cmd response 0x900, card status 0xc00
Jul 26 19:53:36 nitai kernel: [66954.495418] end_request: I/O error, dev mmcblk0, sector 4321651
Jul 26 19:53:36 nitai kernel: [66954.855036] mmcblk0: response CRC error sending r/w cmd command, card status 0x800e00
Jul 26 19:53:36 nitai kernel: [66954.855104] mmcblk0: error -84 sending status command, retrying
Jul 26 19:53:36 nitai kernel: [66954.855128] mmcblk0: timed out sending r/w cmd command, card status 0xe00
Jul 26 19:53:36 nitai kernel: [66954.855186] mmcblk0: timed out sending r/w cmd command, card status 0x400e00
Jul 26 19:53:36 nitai kernel: [66954.855244] mmcblk0: timed out sending r/w cmd command, card status 0x400e00
Jul 26 19:53:36 nitai kernel: [66954.855301] mmcblk0: timed out sending r/w cmd command, card status 0x400e00
Jul 26 19:53:36 nitai kernel: [66954.855357] mmcblk0: timed out sending r/w cmd command, card status 0x400e00
Jul 26 19:53:36 nitai kernel: [66954.855360] end_request: I/O error, dev mmcblk0, sector 431475
Jul 26 19:53:36 nitai kernel: [66954.855363] Buffer I/O error on device mmcblk0p2, logical block 19827
Jul 26 19:53:36 nitai kernel: [66954.855365] lost page write due to I/O error on mmcblk0p2
Jul 26 19:53:36 nitai kernel: [66954.954944] mmcblk0: response CRC error sending r/w cmd command, card status 0x800b00
Comment 1 Peter Weber 2012-09-09 11:11:50 EDT
I'm facing similar errors with Kernel-3.6.0-rc4 on a t430s.

To reporduce:
1. cp
2. sync -> errors in dmesg
Comment 2 Yann Droneaud 2013-03-13 12:09:24 EDT
See bug #871638 for the fix
Comment 3 Josh Boyer 2013-03-14 14:33:57 EDT

*** This bug has been marked as a duplicate of bug 871638 ***

Note You need to log in before you can comment on or make changes to this bug.