Bug 843447 - in Users -> Add, "Role to assign: <select>" is invisible because of "display: none" in table class GE0DXC4CNWB
in Users -> Add, "Role to assign: <select>" is invisible because of "display:...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Einav Cohen
yeylon@redhat.com
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 07:06 EDT by David Jaša
Modified: 2016-04-18 03:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 07:04:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (78.66 KB, image/png)
2012-07-26 07:06 EDT, David Jaša
no flags Details
DOM inspector screenshot (96.95 KB, image/png)
2012-07-26 07:08 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-07-26 07:06:46 EDT
Created attachment 600481 [details]
screenshot

Description of problem:
in Users -> Add, "Role to assign: <select>" is invisible because of "display: none" in table class GE0DXC4CNWB. The same dialog called from "Configure -> System Permission" works fine

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.1.0-7.el6ev.noarch / si11

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Jaša 2012-07-26 07:08:13 EDT
Created attachment 600482 [details]
DOM inspector screenshot

removal of selected "style='display: none; '" makes the dialog elements reappear.
Comment 2 Itamar Heim 2012-07-28 15:47:47 EDT
einav - isn't this intentional (system roles for users available only via confiure dialog?)
Comment 3 Einav Cohen 2012-08-01 07:04:10 EDT
the "add users" dialog is a dialog for adding users to the system, without any permission(s) assigned to them (for adding users with permissions, there is the "add permission" dialog, either from an object context or from the "configure" dialog for adding system-wide permissions).

This is by design.

You are seeing the "display: none" attribute in the relevant table class since the "add users" dialog is actually identical to the "add permission" dialog, with the difference of hiding the "Role" drop-down (again, by design) -> closing.

Note You need to log in before you can comment on or make changes to this bug.