Bug 843461 - when rebooting with two screens with different resolution plymouth gets crooked
when rebooting with two screens with different resolution plymouth gets crooked
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: plymouth (Show other bugs)
7.0
x86_64 Linux
unspecified Severity low
: beta
: 7.0
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 07:41 EDT by Vladimir Benes
Modified: 2014-09-13 14:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.8.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:37:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
camera screens shot (2.34 MB, image/jpeg)
2012-07-26 07:45 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-07-26 07:41:40 EDT
Description of problem:
ssia, I have 1920x1080 and 1680x1050 screens and while rebooting the screen looks like in the picture I attached.

Version-Release number of selected component (if applicable):
plymouth-0.8.5-0.2012.04.27.2.el7

How reproducible:
always

Steps to Reproduce:
1.attach those above mentioned screens
2.reboot

  
Actual results:
crooked screen

Expected results:
both screens filled with color

Additional info:
Comment 1 Vladimir Benes 2012-07-26 07:45:51 EDT
Created attachment 600490 [details]
camera screens shot
Comment 2 Ray Strode [halfline] 2012-07-26 12:41:14 EDT
I believe this should be fixed by:

http://cgit.freedesktop.org/plymouth/commit/?id=4587ac4c31521deaa04c2471b89d9156c4918040
Comment 3 Martin 2014-02-18 10:27:32 EST
It's not fixed, still reproducible when booting with 2 screens with different resolution.
Comment 4 Ray Strode [halfline] 2014-02-18 11:33:51 EST
well i do believe it was fixed, it's just rebroken again after udev device enumeration was added.
Comment 6 Martin 2014-02-27 12:07:46 EST
I don't see this problem now with:

dracut-033-137.el7.x86_64
plymouth-0.8.9-0.8.20140113.el7.x86_64
kernel-3.10.0-97.el7.x86_64
Comment 7 Ludek Smid 2014-06-13 06:37:39 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.