Bug 843493 - [RHEV-H 6.3] TUI:better to keep Rsyslog and Netconsole can't be set before configuring network
[RHEV-H 6.3] TUI:better to keep Rsyslog and Netconsole can't be set before co...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 09:08 EDT by haiyang,dong
Modified: 2016-04-26 11:15 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, it was possible to configure rsyslogd and netconsole, two network dependant services, on a Red Hat Enterprise Virtualization Hypervisor node without networking properly configured. This was potentially confusing. Now, it is not possible to configured rsyslogd and netconsole on a hypervisor node until networking is configured, and a hint has been added to the configuration screen for these services to inform users that networking must be configured first.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:37:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-07-26 09:08:06 EDT
Description of problem:
If not configure network,the Rsyslog and Netconsole can be configured in Logging Page.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120710.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1.Install RHEV-H(make sure you didn't configure network first)
2.Configure Rsyslog server and netconsole server under Logging Page.
3.Focus on Logging menu.
4.Then drop to shell, check the status of rsyslog/netconsole service

Actual results:
1. Server Address/Server Port fields of Rsyslog and Netconsole show configuration info in Logging menu..
2. rsyslog service is running, and netconsole module not loaded

Expected results:
1.Rsyslog/Netconsole service can't be set before configuring network.
2.Server Address/Server Port fields of Rsyslog and Netconsole should be grayed in Logging Page.

Additional info:

--
Comment 2 Fabian Deutsch 2012-09-07 03:52:00 EDT
I see two ways
(a) graying out the entry fields or
(b) add a note that the network has to be configured

Maybe it makes sense to use a and b, otherwise teh user might not know why it's grayed out.
Comment 3 Mike Burns 2012-09-07 07:01:35 EDT
Take a look at the RHEV-M or ovirt-engine configuration screen without network enabled.  We should do something similar to be consistent.
Comment 4 Fabian Deutsch 2012-09-13 05:22:29 EDT
The following (upstream) patch introduces a hint that the network is down and grays out all input fields when no network is available.

http://gerrit.ovirt.org/7979

Tested as follows:
1. Apply patch
2. Disable the network
3. Navigate to Logging page, heading is changed and entries are disabled.
4. Enable network
5. Navigate to Logging page, heading is normal and entries are enabled.
Comment 7 cshao 2012-10-31 01:49:14 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6.
ovirt-node-2.5.0-7.el6_4.noarch

Test steps:
1. Disable the network
2. Navigate to Logging page, heading is changed and entries are disabled.
3. Enable network
4. Navigate to Logging page, heading is normal and entries are enabled

So the bug is fixed, change bug status to VERIFIED.
Comment 8 haiyang,dong 2012-12-27 00:33:41 EST
so follow steps of comment 7 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 10 errata-xmlrpc 2013-02-28 11:37:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.