Bug 843510 - Clicking of buttons before editor proper has loaded around topic XML textarea results in undefined behaviour.
Clicking of buttons before editor proper has loaded around topic XML textarea...
Status: CLOSED WONTFIX
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 09:58 EDT by Stephen Gordon
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 16:11:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-07-26 09:58:04 EDT
Steps to Reproduce:
1. Create a blank topic using CSP.
2. Open topic in edit mode in skynet, immediately click 'Generate from Template'.
3. Once the topic xml textarea is filled with the template data, but before the editor proper has reloaded around it, click save.
  
Actual results:

If your save click beats the editor (happens more often than you would think if you have some latency between  you and the server thanks to being in say, Toronto) then the data doesn't actually save. The user is then presented with a screen where the template data is in the text area but no topic id or title is set anymore (seems to be ready to create a new topic?).

Expected results:

If loading the editor proper is required for buttons to work then they should be disabled until it is loaded.
Comment 1 Matthew Casperson 2013-03-06 16:11:44 EST
The old UI will be retired, and no updates will be made to it. Please use the new UI at http://skynet.usersys.redhat.com:8080/pressgang-ccms-ui/

Note You need to log in before you can comment on or make changes to this bug.