Bug 843514 - [eap6] JAXR subsystem resource configuration cannot be unset (undefined)
[eap6] JAXR subsystem resource configuration cannot be unset (undefined)
Status: CLOSED DUPLICATE of bug 844434
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.1.1
x86_64 Linux
medium Severity medium
: ---
: JON 3.1.2
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2012-07-26 10:06 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 09:10:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2012-07-26 10:06:56 EDT
Description of problem:
Initially the property "class") for jaxr subsystem is "null", while after adding a value, it is not possible to unset it  (same for jndi-name). 

Version-Release number of selected component (if applicable):
Jon 3.1.0
eap6 er6

How reproducible:
always

Steps to Reproduce:
1. set a value for jaxr property configuration class and save it
2. un-set the value of class configuration property of jaxr subsystem and save it

  
Actual results:
it does unset the value and then previously set value is being over-written again

Expected results:
value should be unset

Additional info:
under eap cli undefine-attribute marks class value as "undefined" and it is being unset.
Comment 1 Charles Crouch 2012-07-30 11:50:26 EDT
Should be investigated as to whether this field should be required or if something else is going on here
Comment 2 Charles Crouch 2012-08-02 22:01:22 EDT
Assigning to Simeon since I think he is already looking at a similar issue.
Comment 3 Simeon Pinder 2012-08-07 09:10:27 EDT
Closing this as it's a duplication of BZ 844434. This unset problem affects all AS7 resources where a simple property is being 'unset' back to null.

*** This bug has been marked as a duplicate of bug 844434 ***

Note You need to log in before you can comment on or make changes to this bug.