Bug 843533 - evince: send to by email doesn't 'do' anything with no client installed
evince: send to by email doesn't 'do' anything with no client installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus-sendto (Show other bugs)
7.0
x86_64 Linux
unspecified Severity low
: beta
: ---
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 10:42 EDT by Vitezslav Humpa
Modified: 2014-06-18 04:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:31:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2012-07-26 10:42:55 EDT
Description of problem:
If you open some document in Evince, there is a File->Send To option. You can select 'email' as a method of deliver. If you have no client installed and selected in control-center:Details->Default Applications, you are still allowed to use this method, type a destination email address and press send, keeping you under illusion that all went fine and file got delivered while in reality nothing happened.

Version-Release number of selected component (if applicable):
evince-3.4.0-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have no email client installed, or selected in the control-center
2. In evince, go File->Send to...
3. Choose a Email method
4. Type in some email and press send
  
Actual results:
Nothing happens

Expected results:
You are not allowed to use the Email method in the first place as there is no email client selected in system for this to use.
Comment 1 Marek Kašík 2012-10-24 12:57:48 EDT
This seems to be fixed in nautilus-sendto-3.6.0-1.el7. Email method is not listed in the combo box if there is no email client.
Comment 3 Michael Boisvert 2013-12-16 17:21:53 EST
I believe the new Send To button only does email sending in the first place. 

I tested this in another (duplicate?) bug: https://bugzilla.redhat.com/show_bug.cgi?id=1037788

With no mail client set up: "Send To.." button is greyed out.
With client set up: "Send To..." opens evolution and sends successfully.

Switching to verified.
Comment 4 Ludek Smid 2014-06-13 07:31:37 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.