Bug 843561 - PPC64 installs fail after 0.9 upgrade
PPC64 installs fail after 0.9 upgrade
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
ppc64 Linux
unspecified Severity urgent (vote)
: 0.9.2
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 11:52 EDT by Stefanie Forrester
Modified: 2012-08-09 12:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:07:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefanie Forrester 2012-07-26 11:52:43 EDT
Description of problem:
Provisioning PPC64 machines with RHEL 4.* fails with the following error on boot:

DEFAULT CATCH!, exception-handler=fff00700
at   %SRR0: 0000000004080000   %SRR1: 0000000000023002
Open Firmware exception handler entered from non-OF code

Version-Release number of selected component (if applicable):
0.9.0, 0.9.1

How reproducible:
Always

Steps to Reproduce:
1. Attempt to provision RHEL 4.* on a PPC64 host.
2. Click on "Distro" used in the Beaker job, and view the tree.
3. iSeries kernel is in place where the PPC64 kernel should be. This kernel fails to boot. (RHEL-4/U8/AS/ppc/tree/ppc/iSeries/ on all lab controllers)
  
Actual results:
Fails when attempting to boot kernel image.

Expected results:


Additional info:
Beaker is using the wrong kernel for PPC64 installs of RHEL 4. This is affecting all PPC64 machines since the 0.9 upgrade.
Comment 1 Bill Peck 2012-07-30 11:50:15 EDT
http://gerrit.beaker-project.org/#/c/1251/1
Comment 2 Dan Callaghan 2012-08-09 04:07:01 EDT
Beaker 0.9.2 has been released.
Comment 3 Phil Cassaro 2012-08-09 11:51:57 EDT
I'm still seeing the same failure in 0.9.2

Note You need to log in before you can comment on or make changes to this bug.