Bug 84357 - Multihead (Nvidia TNT2 + voodoo 3) Fails To Start
Multihead (Nvidia TNT2 + voodoo 3) Fails To Start
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-02-14 17:27 EST by Seth Ladd
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-24 15:37:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
PCI list from /proc/pci (2.43 KB, text/plain)
2003-02-14 17:29 EST, Seth Ladd
no flags Details
XF86Config (3.99 KB, text/plain)
2003-02-14 17:30 EST, Seth Ladd
no flags Details
X log from multihead attempt (19.45 KB, text/plain)
2003-02-19 09:45 EST, Seth Ladd
no flags Details
The config used when I generated the X log. (3.99 KB, text/plain)
2003-02-19 09:48 EST, Seth Ladd
no flags Details
XF86Config for 2 voodoo3 w/ NO nVidia (3.92 KB, text/plain)
2003-02-26 11:57 EST, Seth Ladd
no flags Details

  None (edit)
Description Seth Ladd 2003-02-14 17:27:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
When attempting to start a multihead X session (with xinerama or not), neither
monitor comes to life and any attempts to quit X fail.  No logs are produced in
/var/log for the failed session.

When running in single screen mode (using AGP as the device) X works fine. 
Also, if I take out the AGP card and use only the PCI (voodoo) card, that works
in single device mode, too.

This hardware configuration w/ xinerama worked great w/ Redhat 7.3 and Mandrake
9.  Because of this, I believe the hardware is fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Place TNT2 into AGP.
2. Place 3dfx voodoo 3 into PCI slot.
3. Use included XF86Config file.

Actual Results:  Both monitors blank out, no HD activity.  Only hard reset will
work at this point.

Expected Results:  X to start, and for gnome (in my case) to start as well.

Additional info:

When I attempt to run X -configure, that also shows the same behavior.  The
screens blank out and that's it until reboot.  Also, when I run X -scanpci,
nothing comes back.

Not sure this is a bug or misconfiguration.  I followed all Xinerama HOWTOs, and
I believe I did the same exact things that I did when I got this to work on 7.3
and mandrake 9.0.  I wish I kept those configuration files.
Comment 1 Seth Ladd 2003-02-14 17:29:02 EST
Created attachment 90099 [details]
PCI list from /proc/pci

My current hardware setup, from /proc/pci.
Comment 2 Seth Ladd 2003-02-14 17:30:54 EST
Created attachment 90100 [details]

my XF86Config, from /etc/X11.  Notice how I actually have a total of three
devices, but am only attempting to get 2 to work right now.
Comment 3 Seth Ladd 2003-02-14 17:32:08 EST
I wanted to add, I did read through bugzilla re: this issue.  I saw a few posts
about how DRI doesn't work w/ 16b color.  That's fine, I don't want DRI anyway,
so I attempted to disable it (see attached XF86Config file).
Comment 4 Michael Fratoni 2003-02-15 00:10:07 EST
Using the links to create an attachment, could you please post your 
log file?
Comment 5 Seth Ladd 2003-02-15 20:29:40 EST
Hello and thanks for the quick response,

I'm 99% sure that no log message is created in /var/log when I try to run
multihead.  I believe this to be the case because I check those logs after the
freezes, and the lines "ServerLayout" (always near top) never prints the
ServerLayout when I try to run multihead.

To be double sure, I'll delete all X logs and try multihead to see what is
generated.  I'll do this Monday.

If that doesn't work, is there a way to capture what is printed to stdout/stderr
when X runs?  Because the system freezes, I can't ever see that text.  Maybe a
redirect of the output to a file?

Comment 6 Mike A. Harris 2003-02-16 08:17:35 EST
What you read was incorrect.  DRI works fine at 16bit depth.  In fact,
on Voodoo 3 hardware, the card itself _only_ supports 3D at 16bit depth,
but this is not a DRI limitation, it's a hardware limitation.

DRI does not work in Xinerama configurations with any hardware, again, not
a bug, just an unimplemented feature.

Note that if you are using a 3Dfx card in a dualhead setup, your BIOS
_must_ have the 3Dfx card configured to be the primary vga device, or
XFree86 will be unable to initialize the BIOS on the card itself.

Please remove the Voodoo II from the machine entirely to ensure it is
not causing additional problems.

XFree86 outputs a log file into /var/log/XFree86.0.log, which should
be there.  Please attach it.  You don't need to output redirect the
X server's startup messages, as they are logged to the log file.  When your
system reboots back into text mode, that is when you can snag the log

Make sure DRI is disabled while using xinerama.

Comment 7 Seth Ladd 2003-02-19 09:45:34 EST
Created attachment 90187 [details]
X log from multihead attempt

Log from when I tried xinerama w/ multihead.  As usual, screen blanks, no HD
activity, and I had to force reset the box.
Comment 8 Seth Ladd 2003-02-19 09:48:01 EST
Created attachment 90188 [details]
The config used when I generated the X log.

Latest attempt at configuring X for xinerama.  Notice how DRI is turned off.
Comment 9 Seth Ladd 2003-02-19 09:51:29 EST
As per your instructions, I turned the Voodoo 3 to be the primary Video device
on the system.  I am now writing this from the voodoo.

I also disabled DRI (check the latest XF86Config I attached).

I'm sure the hardware is not the problem.  These same cards in their same spots
were working as a Xinerama setup less than a week ago under Mandrake 9.
Comment 10 Markus Kotilainen 2003-02-25 18:36:19 EST
I upgraded from RH 8.0 to Phoebe and I get same problem with Radeon + Voodoo3
multihead configuration. With single screen layout (radeon or voodoo3) works fine.
Comment 11 Mike A. Harris 2003-02-25 19:04:11 EST
It looks like the Nvidia nv driver is having problems perhaps.  Please
update to the latest release of X in rawhide, and if the problem persists,
please report it to xfree86@xfree86.org bug report address and mailing list.

Nvidia hardware documentation is not made publically available even under
NDA from Nvidia, so the open source community relies on Nvidia updating the
nv driver themselves and providing bug fixes.
Comment 12 Seth Ladd 2003-02-26 09:31:42 EST
I wanted to rule out the nVidia, too.  I took out the card, so now I only have
two voodoo 3 cards.  I then double checked my XF86Config, and I took out glx,
dbe, and dri.  Funny thing is, when I startx w/ this hw config, everything
blanks out /and/ no log is created in /var/log.

Is there a XF86Config that is known to work w/ 2 voodoo3's?  If so, I'll try
that to rule out a bad XF86Config.  I can also post the recently tried
XF86Config to this bug.

Having said that, I'll upgrade X server to rawhide to see what happens.

Comment 13 Seth Ladd 2003-02-26 11:55:54 EST
OK, no go.  I tried a multihead w/ just two voodoo 3's.  No nVidia card is
installed in the box.

I'll include the XF86Config.  I also updated all the X rpms from rawhide.

No log is created in /var/log, which is especially frustrating.  Also, the
second monitor does get initialized and I see the text voodoo boot up of the
card itself, but this only happens for the second monitor.  The first/main
monitor does not initialize.

As an aside, the fonts look wonderful in pheobe!
Comment 14 Seth Ladd 2003-02-26 11:57:13 EST
Created attachment 90381 [details]
XF86Config for 2 voodoo3 w/ NO nVidia

Yet another attempt to get multihead to work.  This time w/ only two voodoo 3's
installed in box.  Same result: blank screens and no log file produced.
Comment 15 Mike A. Harris 2003-02-26 17:21:03 EST
If using 3Dfx hardware in a dualhead setup, the 3Dfx hardware *must* be
set to the primary video device in your CMOS.  This restriction precludes
using 2 3Dfx cards in a multihead configuration because it is impossible
to have 2 separate cards both be "primary".

After removing one of the 3Dfx cards, and using a single 3Dfx card as
primary, with the Nvidia card as secondary, does dualhead work?
Comment 16 Seth Ladd 2003-02-26 20:48:57 EST
I'm a bit confused about your last statement.  Are you saying it is impossible
to have a multihead setup w/ 2 3Dfx cards?  Remember, in my latest attempt at
multihead, I took out the nVidia card.  Only the two identical 3Dfx cards remain.

In my BIOS, I have changed the video setup from AGP to PCI.

Under Mandrake 9, I did have this setup working: nVidia as primary, voodoo 3,
and then a voodoo 3.  That was three cards in total, with the nVidia AGP card
being primary.  That all worked under multihead.

In the morning I will double check the BIOS and CMOS to see if there is any
other bits I can twiddle.

In the meantime, can you elaborate on your last statement?  The only scenario
right now I'm attempting is 2 3Dfx cards.  I'll worry about the nVidia card
later (unless you believe that the /only/ way to get multi head is for voodoo 3
as primary and nVidia as secondary).

Scenarios that have failed include:

- nVidia as primary
- voodoo 3 as secondary
- voodoo 3 as third

- nVidia as primary
- voodoo 3 as secondary

- voodoo 3 as primary
- nVidia as secondary

- voodoo 3 as primary
- voodoo 3 as secondary
Comment 17 Mike A. Harris 2004-09-24 15:37:39 EDT
Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.