Bug 843647 - grace FTBFS due to libpng changes
grace FTBFS due to libpng changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grace (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 17:23 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 12:37:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add #include for zlib.h, use png_jmpbuf() instead of direct struct access (516 bytes, patch)
2012-07-26 17:23 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 17:23:34 EDT
Created attachment 600609 [details]
add #include for zlib.h, use png_jmpbuf() instead of direct struct access

Description of problem:
grace has failed the last couple of Fedora mass rebuilds due to changes in libpng's API.  I attach a patch to fix it.

Version-Release number of selected component (if applicable):
grace-5.1.22-13.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Try to rebuild in rawhide.
Comment 1 Gwyn Ciesla 2012-08-01 12:37:04 EDT
Committed and rebuilt in rawhide.
Comment 2 José Matos 2012-08-01 12:43:44 EDT
Thank you Jon.
Comment 3 José Matos 2012-11-26 08:55:15 EST
A late note just to thank Tom for the original patch (I have honestly forgot to do it in comment #2).

Incidentally I am reviewing this bug because I will remove the patch since the latest release 5.1.23 already incorporated this change. :-)

Note You need to log in before you can comment on or make changes to this bug.