Bug 843648 - gshutdown FTBFS with recent glib
gshutdown FTBFS with recent glib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gshutdown (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavier Lamien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 17:39 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 12:24:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update glib header includes (3.39 KB, patch)
2012-07-26 17:39 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 17:39:48 EDT
Created attachment 600612 [details]
update glib header includes

Description of problem:
gshutdown has failed the last couple of mass rebuilds in Fedora.  The reason is that glib now insists that you only include <glib.h> and not any of the individual header files that used to be available.  I attach a patch to fix it.

Version-Release number of selected component (if applicable):
gshutdown-0.2-11.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Try to build in rawhide.
Comment 1 Gwyn Ciesla 2012-08-01 12:24:56 EDT
Committed and built in rawhide.

Note You need to log in before you can comment on or make changes to this bug.