Bug 843655 - pngnq FTBFS with libpng 1.5
pngnq FTBFS with libpng 1.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pngnq (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gerd Hoffmann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 18:17 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:04:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix includes for libpng 1.5 (551 bytes, patch)
2012-07-26 18:17 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 18:17:06 EDT
Created attachment 600624 [details]
fix includes for libpng 1.5

Description of problem:
pngnq has failed the last couple of Fedora mass rebuilds, because in libpng 1.5, png.h no longer includes zlib.h.  I attach a patch to fix it.

Version-Release number of selected component (if applicable):
pngnq-1.1-4.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Try to build in rawhide.

Additional info:
Although it compiles with this change, I noticed a couple warnings that should probably be looked into:

rwpng.c: In function 'rwpng_read_image':
rwpng.c:134:7: warning: passing argument 3 of 'png_get_IHDR' from incompatible pointer type [enabled by default]
In file included from rwpng.c:35:0:
/usr/include/libpng15/png.h:2159:22: note: expected 'png_uint_32 *' but argument is of type 'ulg *'
rwpng.c:134:7: warning: passing argument 4 of 'png_get_IHDR' from incompatible pointer type [enabled by default]
In file included from rwpng.c:35:0:
/usr/include/libpng15/png.h:2159:22: note: expected 'png_uint_32 *' but argument is of type 'ulg *'

If "ulg" isn't always 32 bits, these probably are pointing out platform-specific  misbehaviors.
Comment 1 Gwyn Ciesla 2012-08-01 11:59:59 EDT
Committed and build in rawhide.
Comment 2 Sergio Monteiro Basto 2012-10-18 16:26:30 EDT
Also FTBFS on F17 and we should have pngnq compiled with gcc 4.7 on F17 since mass rebuild of F17 (https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild) to pngnq Failed !
Comment 3 Gwyn Ciesla 2012-10-19 08:51:30 EDT
Does the available build, pngnq-1.1-1.fc15, not work?
Comment 4 Tom Lane 2012-10-19 10:05:57 EDT
I think the point is that it FTBFS, which is a grievous sin for open-source software.  What's the point of being open-source if you can't recompile it?

If you want a less abstract argument for fixing it: what if you had to apply a security patch tomorrow?
Comment 5 Gwyn Ciesla 2012-10-19 10:14:13 EDT
Fair enough, I'll backport.
Comment 6 Fedora Update System 2012-10-19 10:27:58 EDT
pngnq-1.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pngnq-1.1-5.fc17
Comment 7 Fedora Update System 2012-10-19 19:53:28 EDT
Package pngnq-1.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pngnq-1.1-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16484/pngnq-1.1-5.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-12-20 11:04:25 EST
pngnq-1.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.