This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 843658 - tucnak2 FTBFS with libpng 1.5
tucnak2 FTBFS with libpng 1.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tucnak2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lucian Langa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 18:57 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 11:47:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libpng 1.5 fixes (6.30 KB, patch)
2012-07-26 18:57 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 18:57:03 EDT
Created attachment 600629 [details]
libpng 1.5 fixes

Description of problem:
tucnak2 has failed the last couple of Fedora mass rebuilds, because it tries to access the png_info struct directly, which is no longer allowed in libpng 1.5.  There is also a hard-wired assumption in the configure script that the library is named libpng12.  I attach a patch to fix it.

Version-Release number of selected component (if applicable):
tucnak2-2.31-5.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Try to build in rawhide.
Comment 1 Gwyn Ciesla 2012-08-01 11:47:38 EDT
Committed and build in rawhide.

Note You need to log in before you can comment on or make changes to this bug.