Bug 843660 - libnfc broken with pcsc-lite-ccid-1.4.6
libnfc broken with pcsc-lite-ccid-1.4.6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libnfc (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: François Kooman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 19:06 EDT by Manuel Bejarano
Modified: 2012-08-09 19:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:30:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libnfc usb enumeration patch (333 bytes, patch)
2012-07-26 19:06 EDT, Manuel Bejarano
no flags Details | Diff

  None (edit)
Description Manuel Bejarano 2012-07-26 19:06:14 EDT
Created attachment 600632 [details]
libnfc usb enumeration patch

Hi,

There is a problem caused by pcsc-lite-ccid updating the names for some devices under the same USB PID that leads to libnfc-examples tools not detecting the touchatag reader (among others, I guess). Please, see bug 832983.

The attached patch solves the problem. Please, consider applying it to the current libnfc present in Fedora repositories.

I tried to do the same using the last libnfc available upstream but, after a succesful compilation, none of the tools seemed to work, throwing segmentation fault in all the cases. This happens with or without the patch.

Thanks you!
Comment 1 Fedora Update System 2012-07-30 09:13:30 EDT
libnfc-1.4.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libnfc-1.4.2-5.fc17
Comment 2 Fedora Update System 2012-07-30 18:24:10 EDT
Package libnfc-1.4.2-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libnfc-1.4.2-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11283/libnfc-1.4.2-5.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-08-09 19:30:49 EDT
libnfc-1.4.2-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.