Bug 843662 - xmedcon FTBFS with libpng 1.5
xmedcon FTBFS with libpng 1.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xmedcon (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ankur Sinha (FranciscoD)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 19:31 EDT by Tom Lane
Modified: 2013-07-02 23:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 22:20:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update libpng usage (1.67 KB, patch)
2012-07-26 19:31 EDT, Tom Lane
no flags Details | Diff

  None (edit)
Description Tom Lane 2012-07-26 19:31:07 EDT
Created attachment 600637 [details]
update libpng usage

Description of problem:
xmedcon has failed the last couple of Fedora mass rebuilds because libpng 1.5 no longer allows direct access to the png_info struct.  I attach a patch to fix it.

Version-Release number of selected component (if applicable):
xmedcon-0.10.7-8.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Try to build in rawhide.
Comment 1 Ankur Sinha (FranciscoD) 2012-07-27 21:25:04 EDT
Thanks Tom. I'll look into it today. 

Ankur
Comment 2 Ankur Sinha (FranciscoD) 2012-07-27 22:20:55 EDT
Built for rawhide: http://koji.fedoraproject.org/koji/buildinfo?buildID=344741

Building for f16 and f17 now. 

Thanks for the patch Tom!

Ankur
Comment 3 Fedora Update System 2012-07-28 02:30:56 EDT
xmedcon-0.10.7-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xmedcon-0.10.7-9.fc16
Comment 4 Fedora Update System 2012-07-28 02:31:07 EDT
xmedcon-0.10.7-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xmedcon-0.10.7-9.fc17
Comment 5 Fedora Update System 2012-08-14 05:22:52 EDT
xmedcon-0.10.7-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-08-22 16:56:10 EDT
xmedcon-0.10.7-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.