Bug 843666 - Need user access to /dev/snd/seq
Summary: Need user access to /dev/snd/seq
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FedoraAudio
TreeView+ depends on / blocked
 
Reported: 2012-07-27 00:34 UTC by Orcan Ogetbil
Modified: 2012-09-26 08:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 08:51:37 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orcan Ogetbil 2012-07-27 00:34:57 UTC
Due to changes in udev on F-17, /dev/snd/seq does not have proper ACL for the logged in user. As a result, any user ((e.g. audio production users) trying to access the Alsa sequencer device gets denied. Please see bug #827655 for background. F-16 does not have this issue.

The solution to the problem is to include a file 
   $ echo snd_seq > /etc/modules-load.d/seq.conf

We thought that this file might be suitable for the alsa-lib package. Could you please include such a file in the alsa-lib package?

Thanks!

Comment 1 Brendan Jones 2012-08-13 22:11:14 UTC
I was wondering if there was any update on this? This bug is of keen interest to the Fedora Audio spin team.

Thanks

Comment 2 Orcan Ogetbil 2012-08-26 14:09:50 UTC
Brendan, Fernando,
Could you try adding yourself to the "audio" usergroup, logoff/login, and see if you still have the errors?

Comment 3 Jaroslav Kysela 2012-09-06 13:20:13 UTC
I backported the f18 changes (added back the /lib/modprobe.d/dist-alsa.conf file) to alsa-lib-1.0.26.1 .

Comment 4 Fedora Update System 2012-09-07 12:23:00 UTC
python-alsa-1.0.26-1.fc17, alsa-plugins-1.0.26-1.fc17, alsa-tools-1.0.26.1-1.fc17, alsa-utils-1.0.26-1.fc17, alsa-lib-1.0.26-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-alsa-1.0.26-1.fc17,alsa-plugins-1.0.26-1.fc17,alsa-tools-1.0.26.1-1.fc17,alsa-utils-1.0.26-1.fc17,alsa-lib-1.0.26-1.fc17

Comment 5 Fedora Update System 2012-09-09 02:52:34 UTC
Package python-alsa-1.0.26-1.fc17, alsa-plugins-1.0.26-1.fc17, alsa-tools-1.0.26.1-1.fc17, alsa-utils-1.0.26-1.fc17, alsa-lib-1.0.26-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-alsa-1.0.26-1.fc17 alsa-plugins-1.0.26-1.fc17 alsa-tools-1.0.26.1-1.fc17 alsa-utils-1.0.26-1.fc17 alsa-lib-1.0.26-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13658/python-alsa-1.0.26-1.fc17,alsa-plugins-1.0.26-1.fc17,alsa-tools-1.0.26.1-1.fc17,alsa-utils-1.0.26-1.fc17,alsa-lib-1.0.26-1.fc17
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-09-26 08:51:37 UTC
python-alsa-1.0.26-1.fc17, alsa-plugins-1.0.26-1.fc17, alsa-tools-1.0.26.1-1.fc17, alsa-utils-1.0.26-1.fc17, alsa-lib-1.0.26-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.