Bug 843675 - Evolution is not refreshing Google contacts
Evolution is not refreshing Google contacts
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-26 22:36 EDT by Michael Walton
Modified: 2012-07-27 02:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-27 02:54:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Walton 2012-07-26 22:36:33 EDT
Description of problem:

Evolution is not refreshing contacts added directly
in gmail contacts.

Version-Release number of selected component (if applicable):
3.4.3

How reproducible:


Steps to Reproduce:
1. Make sure that evolution is set up with an address book
   of type "Google". In my case the address book has
   shows several entries which were fetched when
   the address book was created.
1. Go to the gmail homepage
2. From the dropdown menu on the left (that can either be
   "Gmail", "Contacts", or "Tasks", choose contacts
3. Add a dummy contact, such as "test.com" with name "Test".
4. Wait for the Google contacts in evolution to refresh.
   Close and restart evolution. That won't do anything.
   Change the refresh interval in the address book
   properties to 1 minute. That won't do anything either...

  
Actual results:
Address book does not refresh


Expected results:
Address book should refresh, at the specified interval
in the adress book properties. Ideally it should also
refresh when evolution is restarted, and even more ideally
there should be a button to force a refresh at the users
whim.

Additional info:
Comment 1 Michael Walton 2012-07-26 22:56:29 EDT
https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/780050
is a near-identical bug report for Ubuntu.
Comment 2 Michael Walton 2012-07-26 23:50:42 EDT
Quite a few minutes later (I'm not sure how many because i was AFK) the contact I added did appear....In any event the contact should have appeared after 1 minutes when i set the refresh interval to 1 minute and that didn't happen, so there's still a bug.
Comment 3 Milan Crha 2012-07-27 02:54:37 EDT
Thanks for a bug report. I think I know what is going on here. The Google Contacts backends runs in evolution-addressbook-factory, and it doesn't know about changes in book's properties, until it (the factory process) is restarted. That means that your change in refresh interval will be used only either the next login or when you manually stop the evolution-addressbook-factory process. Another related thing is that this process is provided by evolution-data-server, and evolution might not be the only client of it.

I found this filled in upstream as [1], thus I'm moving this there.
Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=660383

Note You need to log in before you can comment on or make changes to this bug.