Bug 843724 - Cleaning up catalog code
Cleaning up catalog code
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: hwcert-catalog
:
Depends On: 844207
Blocks: 733415
  Show dependency treegraph
 
Reported: 2012-07-27 03:54 EDT by Tony Fu
Modified: 2015-06-26 05:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-26 05:59:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony Fu 2012-07-27 03:54:30 EDT
Description of problem:


Current catalog code include many bugzilla specific code which are not particular useful for hwcert certs.  Those code were copied from old bugzilla code in the first place and make our catalog code in a messy state in terms of maintaining.  Alos they make our code not easy to read and can potentially decrease the system performance.

We need to find out those useless code and remove them from catalog code.  Since there is a little possibility that the process may cripple catalog system, we should do it in a slow and incremental way.

Now I open this bug as a tracker of code cleaning up process.

The file we need to clean up are, but not limit to, cgi files, pm files and templates.  We can open a separate bug for each specific file we need to clean up and block this tracker.

Note You need to log in before you can comment on or make changes to this bug.