Bug 843738 - Update Wayland to latest upstream version - 0.95
Summary: Update Wayland to latest upstream version - 0.95
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: wayland
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 852619
TreeView+ depends on / blocked
 
Reported: 2012-07-27 08:39 UTC by Diego
Modified: 2012-09-20 06:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-20 06:14:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Diego 2012-07-27 08:39:42 UTC
Description of problem:

Wayland package is outdated. Wayland 0.95 is out.
http://lists.freedesktop.org/archives/wayland-devel/2012-July/004542.html
http://wayland.freedesktop.org/releases.html

Please update to latest upstream version.

Comment 1 Thorsten Leemhuis 2012-09-17 17:28:36 UTC
rawhide was updated, thx ajax

OTOH everything is likely broken on rawhide:

 * cairo afaics needs the patch from Bug 854245
 * weston is still on 0.85 in rawhide (Bug 852619), which is unlikely to work with wayland 0.85 :-/
 * weston 0.95 otoh needs a newer libxkbcommon to compile (see Bug 854261)

I have everything that is needed prepared already, but it needs a recheck now as all those bugs were ignored for two weeks :-/

How to move forward? Ajax?


Note You need to log in before you can comment on or make changes to this bug.