Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 843776 - pyflakes: Remove wildcard imports from python functions
pyflakes: Remove wildcard imports from python functions
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Retired
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks: 843777
  Show dependency treegraph
 
Reported: 2012-07-27 06:50 EDT by Fabian Deutsch
Modified: 2013-11-28 08:32 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 08:32:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-07-27 06:50:00 EDT
Description of problem:
pyflakes can not detect undefined names because many python files in the node sources use "wildcard imports" (from ... import *).

pyflakes:
ovirtnode/log.py:25: 'from ovirtnode.ovirtfunctions import *' used; unable to detect undefined names
Comment 1 Mike Burns 2013-02-05 09:31:57 EST
much of this is done already, but need to revisit and finish cleanup in 2.7.0
Comment 2 Fabian Deutsch 2013-11-28 08:32:52 EST
More stuff go tmigrated to a new codebase. Remaining code migration is tracked in a different bug.

Note You need to log in before you can comment on or make changes to this bug.