Bug 843804 - Syncing fedora 16 produces ORA-01830
Syncing fedora 16 produces ORA-01830
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Pavel Studeník
:
Depends On:
Blocks: sat550-lowbug
  Show dependency treegraph
 
Reported: 2012-07-27 08:03 EDT by Tomáš Kašpárek
Modified: 2012-09-21 05:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: spacewalk-backend-1.7.38-26-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:34:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Kašpárek 2012-07-27 08:03:45 EDT
Description of problem:
When syncing fedora16 packages I am getting this error
(54, 'ORA-01830: date format picture ends before converting entire input string Package Upload Failed due to uniqueness constraint violation. Make sure the package does not have any duplicate dependencies or does not already exists on the server')

Version-Release number of selected component (if applicable):
Spacewalk 1.8 Nightly, Oracle XE backend
code in satellite 5.5 looks exactly the same

How reproducible:
deterministic

Steps to Reproduce:
1. create custom repo labeled fedora16-x86_64-updates, with repoURL: http://ftp.crc.dk/fedora/linux/updates/16/x86_64/
2. associate repo with custom channel labeled fedora16-x86_64-updates
3. run: # spacewalk-repo-sync -c fedora16-x86_64-updates
4. wait till all packages are synced
5. during eratta sync step of spacewalk-repo-sync I get error shown bellow in Actual results
  
Actual results:
[root@XXXXX ~]# spacewalk-repo-sync --channel=fedora16-x86_64-updates
Repo URL: http://ftp.crc.dk/fedora/linux/updates/16/x86_64/
Packages in repo:              9569
No new packages to sync.
Repo http://ftp.crc.dk/fedora/linux/updates/16/x86_64/ has 2808 errata.
2682 errata skipped because of empty package list.
Traceback (most recent call last):
  File "/usr/bin/spacewalk-repo-sync", line 100, in <module>
    sys.exit(abs(main() or 0))
  File "/usr/bin/spacewalk-repo-sync", line 93, in main
    sync.sync()
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/reposync.py", line 101, in sync
    self.import_updates(plugin, url)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/reposync.py", line 129, in import_updates
    self.upload_updates(notices)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/reposync.py", line 286, in upload_updates
    importer.run()
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/importLib.py", line 627, in run
    self.submit()
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/errataImport.py", line 196, in submit
    dml = self.backend.processErrata(self.batch)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backend.py", line 686, in processErrata
    transactional=1)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backend.py", line 1347, in __processObjectCollection
    return self.__processObjectCollection__(objColl, parentTable, childDict, **kwargs)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backend.py", line 1517, in __processObjectCollection__
    return self.__doDML(dml)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backend.py", line 1625, in __doDML
    self.__doInsert(dml.insert, dml.tables)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backend.py", line 1632, in __doInsert
    self.__doInsertTable(tname, dict)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backend.py", line 1646, in __doInsertTable
    insertObj.query(hash)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backendLib.py", line 431, in query
    executeStatement(statement, values, chunksize)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/importlib/backendLib.py", line 456, in executeStatement
    count += statement.executemany(**tempdict)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 172, in executemany
    return apply(self._execute_wrapper, (self._executemany, ) + p, kw)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 108, in _execute_wrapper
    retval = apply(function, p, kw)
  File "/usr/lib/python2.6/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 208, in _executemany
    self._real_cursor.executemany(None, arr)
spacewalk.common.rhnException.rhnFault: (54, 'ORA-01830: date format picture ends before converting entire input string\n', '\n     Package Upload Failed due to uniqueness constraint violation.\n     Make sure the package does not have any duplicate dependencies or\n     does not already exists on the server\n     ')

Expected results:
No traceback

Additional info:
originally reported in spacewalk-list at: https://www.redhat.com/archives/spacewalk-list/2012-July/msg00033.html
Comment 1 Tomáš Kašpárek 2012-07-27 08:06:28 EDT
fix in spacewalk master 84eac652abbf4e8d6c5f6dff3a1343ec8dada7e9
Comment 5 Clifford Perry 2012-09-21 05:34:20 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite

Note You need to log in before you can comment on or make changes to this bug.