This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 843819 - Fix statedump code in nfs xlator
Fix statedump code in nfs xlator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All All
high Severity medium
: ---
: ---
Assigned To: Vivek Agarwal
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 08:45 EDT by Pranith Kumar K
Modified: 2016-02-17 19:03 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:11:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2012-07-27 08:45:58 EDT
Description of problem:
remove gf_logs in statedump codepath.
locks acquired in statedump codepath should not be blocking. Please change the calls to try_lock variants.

This bug is logged because this xlator violates the above rules.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2012-11-24 10:09:51 EST
CHANGE: http://review.gluster.org/4193 (nfs: avoid blocking lock calls in statedump code) merged in master by Vijay Bellur (vbellur@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.