Bug 843861 - Installing the candlepin-cert bootstrap package fails on RHEL5.8+
Installing the candlepin-cert bootstrap package fails on RHEL5.8+
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
1.1.0
Unspecified Unspecified
high Severity high
: beta
: 1.2
Assigned To: Bryan Kearney
Og Maciel
: Triaged
Depends On:
Blocks: 843899
  Show dependency treegraph
 
Reported: 2012-07-27 11:10 EDT by Eric Sammons
Modified: 2013-02-21 14:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 843899 (view as bug list)
Environment:
Last Closed: 2013-02-21 14:17:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-07-27 11:10:24 EDT
Description of problem:
katello-configure will generate a bootstrap file, candlepin-cert and store in /var/www/html/pub.  This file is intended to easily bootstrap a consumer, when installed will install certs and update configurations so that subscription-manager will point to the internal SAM.

When running yum localinstall candlepin-cert*.rpm or rpm -ivh http://fqdn/pub/candlepin-cert*.rpm the command will error out.

Version-Release number of selected component (if applicable):
katello-configure-0.3.7-1.el6_2.noarch

Steps to Reproduce:
1. wget http://fqdn/pub/candlepin-cert-consumer-fqdn-1.0-1.noarch.rpm
2. yum localinstall candlepin-cert-consumer-fqdn-1.0-1.noarch.rpm

also tried:
1. rpm -ivh http://fqdn/pub/candlepin-cert-consumer-fqdn-1.0-1.noarch.rpm

also tried:
1. vi /etc/yum.conf
   set gpgcheck = 0
2. yum localinstall candlepin-cert-consumer-fqdn-1.0-1.noarch.rpm
  
Actual results: 

scenario1: 
Package candlepin-cert-consumer-fqdn-1.0-1.noarch.rpm is not signed

Scneario2:
Retrieving http://fqdn/pub/candlepin-cert-consumer-fqdn-1.0-1.noarch.rpm
error: Failed dependencies:
	rpmlib(FileDigests) <= 4.6.0-1 is needed by candlepin-cert-consumer-fqdn-1.0-1.noarch
	rpmlib(PayloadIsXz) <= 5.2-1 is needed by candlepin-cert-consumer-fqdn-1.0-1.noarch

Scneario3:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(FileDigests) is needed by candlepin-cert-consumer-fqdn-1.0-1.noarch
rpmlib(PayloadIsXz) is needed by candlepin-cert-consumer-fqdn-1.0-1.noarch
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Expected results:
RHEL 5 is a supported consumer, as such the bootstrap option should be supported here and install the candlepin-cert package without issue; updating the necessary files and installing the cert.
Comment 1 Lukas Zapletal 2012-08-01 07:52:42 EDT
This has been already fixed in both CFSE 1.0 and SAM 1.1. I am unable to reproduce on Katello. Do you still have a SAM 1.1 installation with this invalid RPM?

Githash I checked in SAM 1.1 branch: 37554b36250e475a24d2b63ffe7b574dfc257563
Comment 2 Eric Sammons 2012-08-09 14:03:26 EDT
This issue appears to have been addressed in SAM-1.1 and Katello-1.0.4.
Comment 3 Og Maciel 2012-10-10 16:42:45 EDT
Verified (also on latest katello):

SAM
===

* candlepin-0.7.12-1.el6_3.noarch
* candlepin-tomcat6-0.7.12-1.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1h.el6_3.noarch
* katello-cli-common-1.1.10-1h.el6_3.noarch
* katello-cli-headpin-0.2.2-1.el6_2.noarch
* katello-common-1.1.14-2h.el6_3.noarch
* katello-configure-1.1.11-1h.el6_3.noarch
* katello-glue-candlepin-1.1.14-2h.el6_3.noarch
* katello-headpin-1.1.14-2h.el6_3.noarch
* katello-headpin-all-1.1.14-2h.el6_3.noarch
* katello-selinux-1.1.2-1h.el6_3.noarch

CFSE
====
* candlepin-0.7.8.1-1.el6cf.noarch
* candlepin-selinux-0.7.8.1-1.el6cf.noarch
* candlepin-tomcat6-0.7.8.1-1.el6cf.noarch
* katello-1.1.12-14.el6cf.noarch
* katello-all-1.1.12-14.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-7.el6cf.noarch
* katello-cli-common-1.1.8-7.el6cf.noarch
* katello-common-1.1.12-14.el6cf.noarch
* katello-configure-1.1.9-7.el6cf.noarch
* katello-glue-candlepin-1.1.12-14.el6cf.noarch
* katello-glue-pulp-1.1.12-14.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 5 errata-xmlrpc 2013-02-21 14:17:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0544.html

Note You need to log in before you can comment on or make changes to this bug.