Bug 843868 - Wrong deployment destination default for EAP6
Wrong deployment destination default for EAP6
Status: CLOSED DUPLICATE of bug 844217
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 11:23 EDT by dsteigne
Modified: 2012-07-30 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 11:41:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample war file for listed recipe file (10.21 KB, application/octet-stream)
2012-07-27 11:23 EDT, dsteigne
no flags Details

  None (edit)
Description dsteigne 2012-07-27 11:23:35 EDT
Created attachment 600810 [details]
Sample war file for listed recipe file

Description of problem:
When deploying bundles via the JON GUI to a group of JBoss EAP standalone instamces and specify the deployment directory as "." the application ends up in the folder deployment on EAP 6 where it should be deployments.


Version-Release number of selected component (if applicable):
JON 3.1.0

How reproducible:
Everytime

Steps to Reproduce:
1. Using . as the Deployment directory when deploying with the below recipe file:
<?xml version="1.0"?>
<!-- the root project element also contains the project main and everything should match.  otherwise deployment versioning will not be reliably maintained -->
<project xmlns:rhq="antlib:org.rhq.bundle" name="The PmTestWeb application" default="main">
  <!-- the bundle has the project name and the project version as well as a short description-->
  <rhq:bundle name="PmTestWeb" version="1.2" description="PmTestWeb">
    <!-- this has the project name as well as any additional targets to run -->
    <rhq:deployment-unit name="PmTestWeb" preinstallTarget="preinstall" postinstallTarget="postinstall" manageRootDir="false">
      <rhq:url-file url="file:///mnt/repository_test/PmTestWeb.war" destinationFile="PmTestWeb.war"/>
    </rhq:deployment-unit>
  </rhq:bundle>

  <target name="main"/>
  <target name="preinstall">
    <echo>Deploying PmTestWeb to ${rhq.deploy.dir}...</echo>
    <property name="preinstallTargetExecuted" value="true"/>
  </target>
  <target name="postinstall">
    <echo>Done deploying PmTestWeb to ${rhq.deploy.dir}.</echo>
    <property name="postinstallTargetExecuted" value="true"/>

  </target>
</project>
  
Actual results:
war is deployed to the 'deployment' directory, the code is leaving off the s


Expected results:
The war file should be deployed to the EAP6 deployments directory

Additional info:
Comment 1 Charles Crouch 2012-07-30 11:41:01 EDT

*** This bug has been marked as a duplicate of bug 844217 ***

Note You need to log in before you can comment on or make changes to this bug.