This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 843931 - RHC snapshot requires interactive input breaking cucumber tests
RHC snapshot requires interactive input breaking cucumber tests
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 13:40 EDT by Dan Mace
Modified: 2015-05-14 22:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 15:00:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mace 2012-07-27 13:40:11 EDT
Description of problem:

Cucumber tests which use rhc snapshot/restore are, in some cases, resulting in an interactive SSH host authentication prompt which causes the tests to timeout. It seems to happen most frequently when the snapshotting occurs after aliasing or a domain alter.

Version-Release number of selected component (if applicable):


How reproducible:

Run the performance.feature test, placing the snapshotting steps AFTER aliasing/namespace alter.


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Test failure due to interactive prompt.


Expected results:

A passing test.


Additional info:

We have worked around this issue by moving the snapshotting steps to the top of the feature steps, but that is really just masking the problem.
Comment 1 N. Harrison Ripps 2012-08-22 16:35:01 EDT
Assigned.
Comment 2 N. Harrison Ripps 2012-08-23 12:16:08 EDT
Fotios found the root of this issue while investigating a different bug. Reassigning.
Comment 3 Fotios Lindiakos 2012-08-29 18:59:29 EDT
This has been updated in this commit: https://github.com/openshift/rhc/commit/cf4f5c970a5eb8b20e89638f37a0b4fb21e17a5c

It is currently undergoing testing and will be merged with this pull request: https://github.com/openshift/li/pull/323
Comment 4 Chandrika Gole 2012-09-11 17:46:21 EDT
Some other scenarios(line 20, 51) in the same feature file are now failing. Looks like the same root cause where the ssh key is not being uploaded anymore by default 

Tail end of the test results - 

      expected: 0,
           got: 1 (using ==)
      
       Diff:
      @@ -1,2 +1,2 @@
      -0
      +1
       (Spec::Expectations::ExpectationNotMetError)
      ./li/tests/support/../../stickshift/controller/test/cucumber/support/command_helper.rb:257:in `rhc_ctl_stop'
      /usr/lib/ruby/1.8/benchmark.rb:308:in `realtime'
      ./li/tests/support/../../stickshift/controller/test/cucumber/support/command_helper.rb:256:in `rhc_ctl_stop'
      ./li/tests/support/../../stickshift/controller/test/cucumber/support/command_helper.rb:333:in `rhc_do'
      ./li/tests/support/../../stickshift/controller/test/cucumber/support/command_helper.rb:251:in `rhc_ctl_stop'
      ./li/tests/step_definitions/../../stickshift/controller/test/cucumber/step_definitions/application_steps.rb:99:in `/^the application is stopped$/'
      li/tests/performance.feature:59:in `When the application is stopped'

Failing Scenarios:
cucumber li/tests/performance.feature:20 # Scenario: Add and Remove Embedded Cartridegs
cucumber li/tests/performance.feature:51 # Scenario: Namespace Change, Application Alias, Sanpshot, Start, Stop, Restart and Destroy

27 scenarios (2 failed, 25 passed)
270 steps (2 failed, 13 skipped, 255 passed)
Comment 5 Mike McGrath 2012-10-10 14:12:53 EDT
Look at updating the ~/.ssh/config file to exclude Password Auth and only allow public key auth, that will at least make sure the test fails immediately instead of timing out.
Comment 6 Mike McGrath 2012-10-10 14:13:22 EDT
Moved to Jhon during bug triage meeting.

Note You need to log in before you can comment on or make changes to this bug.