Bug 844 - Why not the full GNU enscript? nenscript is a poor man's version of it.
Why not the full GNU enscript? nenscript is a poor man's version of it.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nenscript (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-15 14:56 EST by tt
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-01-15 17:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tt 1999-01-15 14:56:25 EST
Red Hat Linux comes with nenscript, a program for
converting text into PostScript with several formatting
options. As soon as I started using it, I realized that the
capabilities of nenscript are only a small fraction of
those of GNU enscript (which I was using before on my
SPARCstation).  [Note that enscript is 620KB while
nenscript is only 19K.] In particular, GNU enscript allows
one to arbitrarily scale a document, independently in the
horizontal and vertical dimensions; this is a VERY useful
feature.

I wonder why RHL does not distribute the "real McCoy" GNU
enscript instead of the lightweight nenscript.

I've installed GNU enscript on my RHL system from the GNU
distribtuion without any problems.

I've also installed enscript from the RPM distribution at
contrib.redhat.com.  This works fine, except that:
 1) It insists on installing in /usr rather that /usr/local
(which would be my choice for software that I add).
 2) It complains that it wants /usr/local/bin/perl. It
still complained after I put in /usr/local/bin a link to
/usr/bin/perl (that's where perl is in RHL5.2). I the asked
rpm to install it ignoring dependencies, and at that point
it installed fine and ran fine. (Since perhaps perl is
called by enscript only in special circumstances, my test
does not guarantee that my link to perl was to enscript's
liking.)

CONCLUSION:

Why not replace nenscript...rpm by enscript...rpm in the
RHL distribution?  (And in that case make sure that it sits
in /usr/bin and looks for perl in /usr/bin)
				Tom Toffoli
Comment 1 Bill Nottingham 1999-01-15 17:32:59 EST
enscript is in rawhide.

Note You need to log in before you can comment on or make changes to this bug.