Bug 844004 - Using zenity in GDM PreSession scripts no longer prompts user with dialog before login
Using zenity in GDM PreSession scripts no longer prompts user with dialog bef...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.3
All Linux
low Severity low
: rc
: 6.4
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 16:00 EDT by BJ Walker
Modified: 2013-11-21 18:32 EST (History)
3 users (show)

See Also:
Fixed In Version: gdm-2.30.4-40.el6
Doc Type: Bug Fix
Doc Text:
Cause: The PreSession shell script is run before login. Admins are supposed to be able to make the script fail to cancel login. GDM ignores failures, though. Consequence: Login proceeds even when the admin tries to abort it. Fix: GDM now blocks login until the PreSession script finishes, and fails the login process if the PreSession script fails. Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:32:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description BJ Walker 2012-07-27 16:00:26 EDT
Description of problem:
When using the following script:

/usr/bin/zenity --warning --title="CONSENT BANNER" --text "`cat /etc/issue`" --width=750
answer=$?
if [ "$answer" == "1" ] ; then
       exit 1
fi

in /etc/gdm/PreSession/Default, disagreeing with the dialog box no longer kicks user out to login screen.  In RHEL 5, this functionality allowed the admin to provide an EULA to the user, who had to agree with it to continue the login and would be logged out if they disagreed, in RHEL 6 the prompt may appear but does not kick the user out of disagreement.  We were able to work around this by putting in in the Xsession file however it appears the functionality in GDM may have changed.

Version-Release number of selected component (if applicable):
gdm-2.30.4-33.el6_2.x86_64 

How reproducible:
Every time.

Steps to Reproduce:
1. Place the above script in /etc/gdm/PreSession/Default in RHEL 5
2. Login as the user
3. Disagree with the EULA and get kicked out
4. Do the same in RHEL 6 and see the behavior is no longer honored
  
Actual results:
Customers allowed to get into the OS even after disagreement with EULA.

Expected results:
Customers kicked out to login screen when disagreeing with the EULA.

Additional info:
Comment 1 RHEL Product and Program Management 2012-12-14 01:48:14 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Ray Strode [halfline] 2013-06-05 10:37:59 EDT
i believe we fixed this upstream already. devack+
Comment 12 errata-xmlrpc 2013-11-21 18:32:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1708.html

Note You need to log in before you can comment on or make changes to this bug.