Bug 844008 - git p4 support is disabled when NO_PYTHON is enabled
git p4 support is disabled when NO_PYTHON is enabled
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 16:39 EDT by Maciej Piechotka
Modified: 2013-01-10 06:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 10:49:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Piechotka 2012-07-27 16:39:23 EDT
Description of problem:
After update of git python support was disabled.

Version-Release number of selected component (if applicable):
1.7.11.2

How reproducible:
Run any git extension using python.

Steps to Reproduce:
1. Run any git extension using python.
  
Actual results:
git was built without support for ... (NO_PYTHON=1).

Expected results:
Running extension

Additional info:
Comment 1 Todd Zullinger 2012-07-27 17:38:51 EDT
What git extensions are you trying to run?  Setting NO_PYTHON was deliberate.  The python bits in the git tree are only for foreign-scm-helper that is not done, as I understand it.  That's why upstrem doesn't ship them in it's rpm packaging either.

Has that changed?  Can you tell us why you want them to be included?  Git has plenty of subpackages already.  I'm not eager to add more, especially if upstream doesn't consider them ready.
Comment 2 Maciej Piechotka 2012-07-27 18:46:57 EDT
git-p4 is written in python (I use local copy). It worked with the F16 & F17 default git and it have have broken with the update to 1.7.11.2 (it looks like NO_PYTHON did not worked before).
Comment 3 Todd Zullinger 2012-07-27 19:54:58 EDT
NO_PYTHON certainly worked previously (and is still working, just a bit too well perhaps :).  The git-p4.py script was moved from contrib/fast-import to the toplevel of the git tree in 1.7.11.  As part of that move, the installation replaces the git-p4 script with a shell script that outputs the error you received when NO_PYTHON is set.  If you copy the git-p4.py script from the 1.7.11.2 tarball, it appears to function (at least it doesn't have any failed imports).

# This is a copy of the git-p4.py from 1.7.11.2
$ /tmp/git-p4.py 
usage: /tmp/git-p4.py <command> [options]

valid commands: clone, rollback, debug, commit, rebase, branches, sync, submit

Try /tmp/git-p4.py <command> --help for command specific help.

# This is the output that the newly installed git-p4:
$ git p4
fatal: git was built without support for git-p4 (NO_PYTHON=1).

We'll have to work out whether we want to split that into a separate package or not.  But it's not something that was officially supported before.
Comment 4 Paul Collins 2012-08-15 14:17:02 EDT
+1 for splitting it to a separate package. Thus far I've been using cludgy solutions for getting git-p4 to work on Fedora. Needless to say they all break with git gets updated on me. It'd be very nice to have this installable since I use the git p4 integration regularly.
Comment 5 Todd Zullinger 2012-08-15 20:37:29 EDT
I've got a scratch build that I think is in good shape.  I'm going to update git to 1.7.11.5 and work on pushing that into rawhide/f18.  This *may* get pushed down to f17 at some point, but I'm not sure.  No promises.

The f17 scratch build is here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4394559
Comment 6 Fedora Update System 2012-08-15 21:23:02 EDT
git-1.7.11.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-1.7.11.5-1.fc18
Comment 7 Fedora Update System 2012-08-16 12:53:42 EDT
Package git-1.7.11.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing git-1.7.11.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11999/git-1.7.11.5-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-22 06:44:32 EDT
git-1.7.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-1.7.12-1.fc18
Comment 9 Fedora Update System 2012-08-23 15:55:53 EDT
git-1.7.12-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-1.7.12-2.fc18
Comment 10 Fedora Update System 2012-09-27 12:28:53 EDT
git-1.7.12.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/git-1.7.12.1-1.fc18
Comment 11 Fedora Update System 2012-09-27 12:29:10 EDT
git-1.7.11.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/git-1.7.11.7-1.fc17
Comment 12 Adam Tkac 2012-11-22 10:49:45 EST
This is already fixed in git-1.7.11.7-1.fc17
Comment 13 Adam Tkac 2012-11-22 10:51:26 EST
(In reply to comment #12)
> This is already fixed in git-1.7.11.7-1.fc17

Ah, sorry, I meant git-1.8.0-1.fc18

The fix is not going to be backported to Fedora 17.

Note You need to log in before you can comment on or make changes to this bug.