Bug 844027 - SELinux is preventing /usr/bin/kmod from 'getattr' accesses on the file /usr/lib/modules/3.4.6-2.fc17.x86_64/modules.dep.bin.
SELinux is preventing /usr/bin/kmod from 'getattr' accesses on the file /usr/...
Status: CLOSED DUPLICATE of bug 866749
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6f55bed02d8890b8c204bed7aa8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-27 21:25 EDT by Cody Dostal
Modified: 2012-10-17 03:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 03:02:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cody Dostal 2012-07-27 21:25:18 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.6-2.fc17.x86_64
time:           Fri 27 Jul 2012 07:23:36 PM MDT

description:
:SELinux is preventing /usr/bin/kmod from 'getattr' accesses on the file /usr/lib/modules/3.4.6-2.fc17.x86_64/modules.dep.bin.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that kmod should be allowed getattr access on the modules.dep.bin file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep modinfo /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:modules_object_t:s0
:Target Objects                /usr/lib/modules/3.4.6-2.fc17.x86_64/modules.dep.b
:                              in [ file ]
:Source                        modinfo
:Source Path                   /usr/bin/kmod
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           kmod-7-2.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-140.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux cody-linux 3.4.6-2.fc17.x86_64 #1 SMP Thu
:                              Jul 19 22:54:16 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 27 Jul 2012 07:19:52 PM MDT
:Last Seen                     Fri 27 Jul 2012 07:19:52 PM MDT
:Local ID                      405c7ac7-4a03-4e50-9d21-1d3159fe435f
:
:Raw Audit Messages
:type=AVC msg=audit(1343438392.617:61): avc:  denied  { getattr } for  pid=1458 comm="modinfo" path="/usr/lib/modules/3.4.6-2.fc17.x86_64/modules.dep.bin" dev="sda2" ino=266343 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:modules_object_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1343438392.617:61): arch=x86_64 syscall=fstat success=yes exit=0 a0=4 a1=7fffd5d45710 a2=7fffd5d45710 a3=238 items=0 ppid=1317 pid=1458 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=modinfo exe=/usr/bin/kmod subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: modinfo,system_dbusd_t,modules_object_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-30 05:19:51 EDT
What were you doing when this happened?
Comment 2 distro.ru 2012-10-15 00:53:39 EDT
try to activate bradcom bcm43xx via additional drivers interface. 

Package: (null)
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Miroslav Grepl 2012-10-17 03:02:25 EDT

*** This bug has been marked as a duplicate of bug 866749 ***

Note You need to log in before you can comment on or make changes to this bug.