Bug 844047 - named 9.9.1 does not listen on eth0 as something happen and start before of network correct init
named 9.9.1 does not listen on eth0 as something happen and start before of n...
Status: CLOSED DUPLICATE of bug 837173
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-28 06:11 EDT by Alberto Colosi
Modified: 2013-04-30 19:52 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
fc 17 with yum update isc bind (named) start before of network and listen only on lo 127.0.0.1 is widely reported on the net before yum update it was not happening
Last Closed: 2012-07-30 11:35:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alberto Colosi 2012-07-28 06:11:18 EDT
Description of problem:
named 9.9.1-P1 or P2 does not listen on eth0 as something happen and start before of network correct init

Version-Release number of selected component (if applicable):

9.9.1-P1 or 9.9.1-P2 Fedora 17 done yum update on 26 july 2012 and got in the problem!. System installed 4 july 2012 and was fine

How reproducible:

9.9.1-P1 or 9.9.1-P2 Fedora 17 done yum update on 26 july 2012 and got in the problem!. System installed 4 july 2012 and was fine

I find many issues on the net about it as one for all
http://www.linuxquestions.org/questions/linux-server-73/named-does-not-listen-on-eth0-right-after-boot-659899/

Steps to Reproduce:
1. install fc17
2. sure to make yum update
3. if after system load I log inside and do via systemctl or service statement a stop and start of ISC NAMED, it is all ok and inside /var/log/messages write to listen not only on lo, 127.0.0.1 but on eth0 if interface too
  
Actual results:


Expected results:


Additional info:
Comment 1 Alberto Colosi 2012-07-28 06:38:31 EDT
possible fix as stated on
https://bugzilla.redhat.com/show_bug.cgi?id=837173

Fix:  Change the four occurrences of "/sbin/systemctl" in /etc/NetworkManager/dispatcher.d/13-named to "/usr/bin/systemctl".

I even changed line 1 as I don't use chroot by now

in all case a 'locate systemctl' say that systemctl is not inside /sbin
but inside /usr/bin so all statements inside /etc/NetworkManager/dispatcher.d/13-named

   *FAIL*

please let me to know
Comment 2 Bill Nottingham 2012-07-30 11:32:52 EDT
That file comes from bind.
Comment 3 Adam Tkac 2012-07-30 11:35:32 EDT

*** This bug has been marked as a duplicate of bug 837173 ***

Note You need to log in before you can comment on or make changes to this bug.