Bug 84405 - Logitech PS/2 Optical Wheel Mouse cannot scroll
Logitech PS/2 Optical Wheel Mouse cannot scroll
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-02-15 16:53 EST by Todd Jones
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-06 03:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Todd Jones 2003-02-15 16:53:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
Installer does not recognize the Logitech ps/2 optical mouse as havig a wheel,
but prompts for Generic 3-button mouse.  This has been this way since 7.1.  I
then go to XF86Config and change the Protocol to IMPS/2 from PS/2 and everything
is happy.
I just upgraded one of my systems to an AsusP4S533-E board with a P4 2.4Ghz
processor.  I installed RH8, and tried to change the mouse protocol to IMPS/2,
and when I do, the mouse acts crazy, which is I believe a sign the wrong
protocol is being used.
In troubleshooting I have searched newsgroups and posted the question to
linux.redhat, and I keep hearing that I should change the protocol to IMPS/2,
which of course, does not work.  I have also swapped out the mouse for an
identical Logitech mouse, to no avail.  The mouse has the following markings on
the bottom.
  M/N: M-BD58
  P/N: 830386-0000
Also, upon starting, if I do not move the mouse around constantly, kudzu detects
that the mouse is disconnected.

I checked and the kudzu issue and the anaconda issue are known bugs, but I could
not find one submitted which had the IMPS/2 problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Exit X to GDM
2.  Edit XF86Config and change the protocol for the mouse to IMPS/2 from PS/2.
3.  Go to GDM and do a CTRL-ALT-Backspace to restart X.

Actual Results:  Mouse moves all over the place, usually in the bottom left
area.  Some buttons are being automatically clicked as well, as the language
link is usually clicked with no user assistance.

Expected Results:  The mouse to behave normally and the mouse wheel to cause the
scroll bar in windows to scroll when activated.

Additional info:

Here is my current mouse device section in my XF86Config.  As stated, it should
have IMPS/2 for the protocol, but I am forced to use PS/2.

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "PS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
Comment 1 Michael Fulbright 2003-02-17 09:56:46 EST
This sounds like a problem post-installation.

Comment 2 Gilbert Fernandes 2003-02-22 06:55:28 EST
I got the same problem. If the mouse (it is an USB one) is plugged as
USB it is not recognized when installing Red Hat but it works after.
In this case, using the mouse scroll works.

If the mouse is plugged, using its USB->PS/2 adapter, it is recognized
when installing Red Hat but no scroll works once the system is used.
I have checked the XF86Config, the Option for ZAxisMapping is there,
and correctly configured.

I'm using a Shuttle SS51G machine (SiS based) and a Logitech USB mouse,
the red translucid one (seems to be widely spread).
Comment 3 Ted Kaczmarek 2003-04-08 23:00:34 EDT
I opened a simillar bug in Phoebe, but I have MousemanPlus PS/2, which worked fine
with 7.2,7.3, 8.0 and all Phoebe's/Rawhide till the 4.3.X versions. 
The weird part is in Phoebe with with Mouseman PlusPS/2 the scroll wheel
would work, but with IMPS/2 it wouldn't. I was informed to try IMPS/2 in Phoebe
with which the scroll wheel never worked. Now with Redhat 9 in which I chose the
Logitech MouseManPlus PS/2 option during setup, the scroll wheel does now work.
Also with Phoebe and if I depressed the scroll wheeel button it would
scroll, I do not see the same behavior with the default install. I will switch
to IMPS/2 after I apply updates and will update with results.

Comment 4 Mike A. Harris 2003-04-09 04:44:59 EDT
I have a Logitech Mouseman+ Wheel mouse which has 4 buttons of which one
is a scroll wheel.  It is configured to use the IMPS/2 protocol, and it
works in every release of Red Hat Linux from 6.0 (when I first got the
mouse) through 9, including on the Alpha, ia64, and x86-64 platforms.  I
switch btween numerous machines with this mouse using the IMPS/2 protocol
and encounter no problems.  The mouse wheel works properly, and the
buttons work properly.  The middle button and the side button mirror each
other, however I've never cared much about it to try and figure out how
to configure each button to be separate.  This is not the same mouse as
yours, but it should work the same protocol-wise.  I do not have the exact
same model of mouse available to me in order to try to investigate this
problem with the exact 100% same hardware.

Please disable gpm via ntsysv, try a different protocol with your mouse
in XFree86, if it doesn't work - reboot in order to force the mouse hardware
to reset which is very important, then try a different protocol.  If you
are unable to get the mouse to work with any protocol, then I'm at a loss
of words as to what the problem could be, and I recommend reporting your
bug in XFree86.org's bugzilla at http://bugs.xfree86.org so that the mouse
driver maintainer can try to determine if perhaps your mouse is some
unsupported variation that works differently from all other Logitech mice
that work properly with the existing 4.3.0 code and the IMPS/2 protocol.

Please update the report with your success/failure of getting the mouse
to work.  Also, if you obtain any information from upstream or from
xfree86@xfree86.org mailing list which you believe may help resolve this
issue, please add it here.

Hopefully some day XFree86 will just autodetect mice and work without
configuration.  ;o/

Comment 5 Mike A. Harris 2004-07-06 03:16:09 EDT
As an update, I've got several Logitech optical wheel mice now also,
some of the snazzy blue ones, and a few of the cheaper white models
with lower DPI.  I've been using them for some time now in
FC2, FC1, RHEL3, and one RHL 8.0 machine.  I'd have to test with
RHL 9, but it should be identical to RHEL3 as far as the X side
is concerned since XFree86 is the same codebase in those two
OS products.  When the mouse is properly configured in the X server
config file, to use protocol "IMPS/2", with ZaxisMapping 4 5,
the mice correctly work as a 3 button scrollwheel.

In Fedora Core 2, one additional change needed, is that you need
to point to /dev/input/mice for proper operation.

Other than that, I am unable to reproduce any problems with Logitech
scrollwheel mice, optical or rollerball.

There is one problem which could occur and cause random mouse and/or
keyboard behaviour, and that is if you _change_ the mouse protocol
to another one trying to get the right protocol, and then try
another one.  If you are using a PS/2 mouse, this often hangs
the controller and requires a full hardware reset quite often,
however it is recoverable sometimes by doing a VTswitch and back.

If in doubt, shutdown the system and power off to really reset
the hardware, and come up with IMPS/2 protocol. Every Logitech
PS/2 or serial mouse I've ever used/borrowed/tested in the last
6-7 years has worked properly with the IMPS/2 protocol.  Serial
mice probably wont work with it however, and "Mouseman" or another
protocol is probably desired.

I'm going to close this bug report as "WORKSFORME" for now, as
I believe this problem is just a configuration problem which
was caused by the config tool not having the technology to uniquely
identify the mouse to a specific brand/model and map it to a
specific protocol - so it uses defaults which may sometimes not
work.  Our config tools are much better nowadays in Fedora Core 2
for this type of problem.

For the case of a misconfigured protocol however, once it is
misconfigured. you can change it to the _right_ protocol and still
end up with broken non-working mouse until a full hardware reset
has occured, as mentioned above.

Any modern PS/2 or USB Logitech mouse should work correctly
with the IMPS/2 protocol, and that has been my experience, so
I'm setting the status of this to "WORKSFORME".

Note You need to log in before you can comment on or make changes to this bug.