Bug 844067 - Selection of input method applied to all windows
Selection of input method applied to all windows
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-28 10:52 EDT by James
Modified: 2012-08-08 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 22:10:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James 2012-07-28 10:52:31 EDT
Description of problem:

Previous ibus can remember choice of IM for different windows. If you use IM1 in window A and IM2 in window B, switching from windows A to B will change the IM from IM1 to IM2. But now choice of input method seems to be "universal", i.e. change of IM in one window will apply to all windows.

Version-Release number of selected component (if applicable):

1.4.99.20120428-2.fc17

How reproducible:

Steps to Reproduce:
1. Open one window, for example gedit
2. Switch input method to, for example, ibus-pinyin
3. Open another window, for example firefox
4. Switch input method in firefox to English
5. Switch back to gedit.
  
Actual results:

Now the input method of gedit is English.

Expected results:

Since the user used ibus-pinyin in gedit previously, it should be still ibus-pinyin when switching back from firefox.
Comment 1 fujiwara 2012-08-08 22:10:33 EDT
In Fedora 17, the input context won't have the local status.
Now the ibus switches XKB keymaps and input methods and XKB keymaps have the global status.
It may be similar with Mac OS and Chrome OS.

Note You need to log in before you can comment on or make changes to this bug.